PageRenderTime 1349ms queryFilters 0ms Sphinxql 921ms GetByIds 332ms meta 0ms repositoryFilters 36ms languageFilters 5ms sourceFilters 34ms

501,203 results for 'php empty repo:asterix14/dolibarr' (1349 ms)

Source

Language

Repository

zend.validator.not-empty.rst https://github.com/gullij/zf2-documentation.git | Unknown | 109 lines
25
26Par défaut, ce validateur fonctionne différement de la fonction *PHP* ``empty()``. En particulier, ce validateur
27va évaluer l'entier **0** et la chaîne '**0**' comme vides.
40
41   Sans configuration ajoutée, ``Zend\Validate\NotEmpty`` diffère de *PHP*.
42
70
71- **php**\  : Retourne ``FALSE`` lorsque la fonction *PHP* ``empty()`` retournerait ``TRUE``.
72
85   // Retourne false pour 0
86   $validator = new Zend\Validate\NotEmpty(Zend\Validate\NotEmpty::INTEGER);
87
89   $validator = new Zend\Validate\NotEmpty(
90       Zend\Validate\NotEmpty::INTEGER + Zend\NotEmpty\NotEmpty::ZERO
91   );
zend.validator.not-empty.rst https://github.com/rixrix/zf2-documentation.git | Unknown | 109 lines
25
26Par défaut, ce validateur fonctionne différement de la fonction *PHP* ``empty()``. En particulier, ce validateur
27va évaluer l'entier **0** et la chaine '**0**' comme vides.
40
41   Sans configuration ajoutée, ``Zend\Validate\NotEmpty`` diffère de *PHP*.
42
70
71- **php**\  : Retourne ``FALSE`` lorsque la fonction *PHP* ``empty()`` retournerait ``TRUE``.
72
85   // Retourne false pour 0
86   $validator = new Zend\Validate\NotEmpty(Zend\Validate\NotEmpty::INTEGER);
87
89   $validator = new Zend\Validate\NotEmpty(
90       Zend\Validate\NotEmpty::INTEGER + Zend\NotEmpty\NotEmpty::ZERO
91   );
history.php https://github.com/Modulaweb/dolibarr.git | PHP | 193 lines
1<?php
2/* Copyright (C) 2003-2005 Rodolphe Quiedeville <rodolphe@quiedeville.org>
25
26require '../../main.inc.php';
27require_once DOL_DOCUMENT_ROOT.'/core/lib/fourn.lib.php';
27require_once DOL_DOCUMENT_ROOT.'/core/lib/fourn.lib.php';
28require_once DOL_DOCUMENT_ROOT.'/fourn/class/fournisseur.commande.class.php';
29
39$socid='';
40if (! empty($user->societe_id)) $socid=$user->societe_id;
41$result = restrictedArea($user, 'fournisseur', $id, '', 'commande');
51
52if ($id > 0 || ! empty($ref))
53{
78
79		$linkback = '<a href="'.DOL_URL_ROOT.'/fourn/commande/liste.php'.(! empty($socid)?'?socid='.$socid:'').'">'.$langs->trans("BackToList").'</a>';
80
View.class.php https://github.com/wujingke/thinkphp.git | PHP | 218 lines
1<?php
2// +----------------------------------------------------------------------
2// +----------------------------------------------------------------------
3// | ThinkPHP [ WE CAN DO IT JUST THINK IT ]
4// +----------------------------------------------------------------------
12/**
13 * ThinkPHP 视图类
14 */
87    private function render($content,$charset='',$contentType=''){
88        if(empty($charset))  $charset = C('DEFAULT_CHARSET');
89        if(empty($contentType)) $contentType = C('TMPL_CONTENT_TYPE');
92        header('Cache-control: '.C('HTTP_CACHE_CONTROL'));  // 页面缓存控制
93        header('X-Powered-By:ThinkPHP');
94        // 输出模板文件
114        ob_implicit_flush(0);
115        if('php' == strtolower(C('TMPL_ENGINE_TYPE'))) { // 使用PHP原生模板
116            $_content   =   $content;
View.class.php https://github.com/guodont/easycart.git | PHP | 212 lines
1<?php
2// +----------------------------------------------------------------------
2// +----------------------------------------------------------------------
3// | ThinkPHP [ WE CAN DO IT JUST THINK IT ]
4// +----------------------------------------------------------------------
12/**
13 * ThinkPHP 视图类
14 */
87    private function render($content,$charset='',$contentType=''){
88        if(empty($charset))  $charset = C('DEFAULT_CHARSET');
89        if(empty($contentType)) $contentType = C('TMPL_CONTENT_TYPE');
92        header('Cache-control: '.C('HTTP_CACHE_CONTROL'));  // 页面缓存控制
93        header('X-Powered-By:ThinkPHP');
94        // 输出模板文件
114        ob_implicit_flush(0);
115        if('php' == strtolower(C('TMPL_ENGINE_TYPE'))) { // 使用PHP原生模板
116            // 模板阵列变量分解成为独立变量
View.class.php https://github.com/398360167/workflow.git | PHP | 228 lines
1<?php
2// +----------------------------------------------------------------------
2// +----------------------------------------------------------------------
3// | ThinkPHP [ WE CAN DO IT JUST THINK IT ]
4// +----------------------------------------------------------------------
12/**
13 * ThinkPHP 视图类
14 * @category   Think
91    private function render($content,$charset='',$contentType=''){
92        if(empty($charset))  $charset = C('DEFAULT_CHARSET');
93        if(empty($contentType)) $contentType = C('TMPL_CONTENT_TYPE');
96        header('Cache-control: '.C('HTTP_CACHE_CONTROL'));  // 页面缓存控制
97        header('X-Powered-By:ThinkPHP');
98        // 输出模板文件
119        ob_implicit_flush(0);
120        if('php' == strtolower(C('TMPL_ENGINE_TYPE'))) { // 使用PHP原生模板
121            // 模板阵列变量分解成为独立变量
update-core.php https://bitbucket.org/matyhaty/senses-avj-printclub | PHP | 541 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
387	<script type="text/javascript">
388	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
389	</script>
DooValidator.php https://gitlab.com/winiceo/levengit.git | PHP | 1,221 lines
1<?php
2/**
78 * <?php
79 * //in protected/config/forms/example.php
80 * return array(
129	/**
130	 * Use PHP empty method to test for required (or optional)
131	 */
131	 */
132	const REQ_MODE_NULL_EMPTY = 'nullempty';
133
322
323					$vIsEmpty = ($this->requireMode == DooValidator::REQ_MODE_NULL_EMPTY && ($v === null || $v === '') ||
324								 $this->requireMode == DooValidator::REQ_MODE_NULL_ONLY  && $v === null) ? true : false;
923    /**
924     * Validate Not Empty. Input cannot be empty.
925     *
php-var.el git://github.com/ejmr/php-mode.git | Lisp | 264 lines
21;; Variable handling functions
22;; http://php.net/manual/en/ref.var.php
23;; file:///usr/share/doc/php-doc/html/ref.var.html
24
25(define-skeleton php-boolval
26  "Insert a boolval statement"
31 
32(define-skeleton php-debug_zval_dump
33  "Insert a debug_zval_dump"
38
39(define-skeleton php-empty
40  "Insert an empty statement"
129
130(define-skeleton php-is_integer
131  "Insert an is_integer statement"
update-core.php https://bitbucket.org/broderboy/shannonbroder-wordpress | PHP | 541 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
387	<script type="text/javascript">
388	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
389	</script>
update-core.php https://bitbucket.org/sergiohzlz/reportaprod | PHP | 541 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
387	<script type="text/javascript">
388	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
389	</script>
update-core.php https://bitbucket.org/praveen_excell/opshop | PHP | 541 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
387	<script type="text/javascript">
388	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
389	</script>
update-core.php https://bitbucket.org/julianelve/vendor-wordpress | PHP | 546 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
361	<script type="text/javascript">
362	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
363	</script>
update-core.php https://bitbucket.org/opehei/wordpress-trunk | PHP | 546 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
361	<script type="text/javascript">
362	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
363	</script>
CValidator.php https://bitbucket.org/dinhtrung/yiicorecms/ | PHP | 259 lines
1<?php
2/**
145			else
146				$on=preg_split('/[\s,]+/',$params['on'],-1,PREG_SPLIT_NO_EMPTY);
147		}
171
172		$validator->on=empty($on) ? array() : array_combine($on,$on);
173
217	 * <ul>
218	 * <li>the validator's "on" property is empty</li>
219	 * <li>the validator's "on" property contains the specified scenario</li>
226	{
227		return empty($this->on) || isset($this->on[$scenario]);
228	}
245	 * Checks if the given value is empty.
246	 * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
247	 * Note that this method is different from PHP empty(). It will return false when the value is 0.
CValidator.php http://yii.googlecode.com/svn/trunk/ | PHP | 262 lines
1<?php
2/**
145			else
146				$on=preg_split('/[\s,]+/',$params['on'],-1,PREG_SPLIT_NO_EMPTY);
147		}
176
177		$validator->on=empty($on) ? array() : array_combine($on,$on);
178
222	 * <ul>
223	 * <li>the validator's "on" property is empty</li>
224	 * <li>the validator's "on" property contains the specified scenario</li>
230	{
231		return empty($this->on) || isset($this->on[$scenario]);
232	}
249	 * Checks if the given value is empty.
250	 * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
251	 * Note that this method is different from PHP empty(). It will return false when the value is 0.
CValidator.php https://code.google.com/p/monkeys-job/ | PHP | 233 lines
1<?php
2/**
137			else
138				$on=preg_split('/[\s,]+/',$params['on'],-1,PREG_SPLIT_NO_EMPTY);
139		}
163
164		$validator->on=empty($on) ? array() : array_combine($on,$on);
165
191	 * <ul>
192	 * <li>the validator's "on" property is empty</li>
193	 * <li>the validator's "on" property contains the specified scenario</li>
200	{
201		return empty($this->on) || isset($this->on[$scenario]);
202	}
219	 * Checks if the given value is empty.
220	 * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
221	 * Note that this method is different from PHP empty(). It will return false when the value is 0.
CValidator.php git://github.com/pmjones/php-framework-benchmarks.git | PHP | 232 lines
1<?php
2/**
137			else
138				$on=preg_split('/[\s,]+/',$params['on'],-1,PREG_SPLIT_NO_EMPTY);
139		}
163
164		$validator->on=empty($on) ? array() : array_combine($on,$on);
165
191	 * <ul>
192	 * <li>the validator's "on" property is empty</li>
193	 * <li>the validator's "on" property contains the specified scenario</li>
200	{
201		return empty($this->on) || isset($this->on[$scenario]);
202	}
219	 * Checks if the given value is empty.
220	 * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
221	 * Note that this method is different from PHP empty(). It will return false when the value is 0.
update-core.php https://bitbucket.org/jsvana/alfred.git | PHP | 541 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
387	<script type="text/javascript">
388	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
389	</script>
update-core.php https://bitbucket.org/mpizza/aws-pizza.git | PHP | 546 lines
46		} else {
47			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
48			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
53			if ( !$mysql_compat && !$php_compat )
54				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
55			elseif ( !$php_compat )
55			elseif ( !$php_compat )
56				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
57			elseif ( !$mysql_compat )
109			$('dismissed-updates').show();
110			$('#show-dismissed').toggle(function(){$(this).text('<?php echo $hide_text; ?>');}, function() {$(this).text('<?php echo $show_text; ?>')});
111			$('#show-dismissed').click(function() { $('#dismissed-updates').toggle('slow');});
361	<script type="text/javascript">
362	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
363	</script>
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21