PageRenderTime 366ms queryFilters 1ms Sphinxql 151ms app.CodeModel.GetByIds 148ms findMatchingLines 43ms GetByIds 191ms meta 0ms repositoryFilters 14ms languageFilters 9ms sourceFilters 4ms

421,407 results for 'php empty repo:dadyday/template' (366 ms)

Source

Language

Repository

View.class.php https://gitlab.com/yoage/thinkphp.git | PHP | 229 lines
1<?php
2// +----------------------------------------------------------------------
2// +----------------------------------------------------------------------
3// | ThinkPHP [ WE CAN DO IT JUST THINK IT ]
4// +----------------------------------------------------------------------
12/**
13 * ThinkPHP 视图类
14 */
87    private function render($content,$charset='',$contentType=''){
88        if(empty($charset))  $charset = C('DEFAULT_CHARSET');
89        if(empty($contentType)) $contentType = C('TMPL_CONTENT_TYPE');
92        header('Cache-control: '.C('HTTP_CACHE_CONTROL'));  // 页面缓存控制
93        header('X-Powered-By:ThinkPHP');
94        // 输出模板文件
116        ob_implicit_flush(0);
117        if('php' == strtolower(C('TMPL_ENGINE_TYPE'))) { // 使用PHP原生模板
118            $_content   =   $content;
upgrade.php https://gitlab.com/math4youbyusgroupillinois/WordPress.git | PHP | 118 lines
43$mysql_version  = $wpdb->db_version();
44$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
45if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
63<body class="wp-core-ui">
64<h1 id="logo"><a href="<?php echo esc_url( __( 'https://wordpress.org/' ) ); ?>" tabindex="-1"><?php _e( 'WordPress' ); ?></a></h1>
65
73	if ( !$mysql_compat && !$php_compat )
74		printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
75	elseif ( !$php_compat )
75	elseif ( !$php_compat )
76		printf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
77	elseif ( !$mysql_compat )
89<p><?php _e( 'The update process may take a little while, so please be patient.' ); ?></p>
90<p class="step"><a class="button button-large" href="upgrade.php?step=1&amp;backto=<?php echo $goback; ?>"><?php _e( 'Update WordPress Database' ); ?></a></p>
91<?php
upgrade.php https://gitlab.com/geyson/geyson.git | PHP | 127 lines
49$mysql_version  = $wpdb->db_version();
50$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
51if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
79	if ( !$mysql_compat && !$php_compat )
80		printf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version );
81	elseif ( !$php_compat )
81	elseif ( !$php_compat )
82		printf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version );
83	elseif ( !$mysql_compat )
97<p><?php _e( 'The update process may take a little while, so please be patient.' ); ?></p>
98<p class="step"><a class="button button-large" href="upgrade.php?step=1&amp;backto=<?php echo $goback; ?>"><?php _e( 'Update WordPress Database' ); ?></a></p>
99<?php
109	<p><?php _e( 'Your WordPress database has been successfully updated!' ); ?></p>
110	<p class="step"><a class="button button-large" href="<?php echo $backto; ?>"><?php _e( 'Continue' ); ?></a></p>
111
events_test.php git://github.com/moodle/moodle.git | PHP | 637 lines
83        $this->assertEquals(2, $event->relateduserid);
84        $expected = array($this->eventcourse->id, 'scorm', 'delete attempts', 'report.php?id=' . $this->eventcm->id,
85                4, $this->eventcm->id);
116        // Check that the legacy log data is valid.
117        $expected = array($this->eventcourse->id, 'scorm', 'pre-view', 'view.php?id=' . $this->eventcm->id,
118                $this->eventscorm->id, $this->eventcm->id);
224        // Check that the legacy log data is valid.
225        $expected = array($this->eventcourse->id, 'scorm', 'report', 'report.php?id=' . $this->eventcm->id . '&mode=basic',
226                $this->eventscorm->id, $this->eventcm->id);
401            'cmi.core.score.raw => 10' => array('cmi.core.score.raw', '10'),
402            // Check an edge case (PHP empty() vs isset()): score value equals to '0'.
403            'cmi.core.score.raw => 0' => array('cmi.core.score.raw', '0'),
409            'cmi.score.raw => 10' => array('cmi.score.raw', '10'),
410            // Check an edge case (PHP empty() vs isset()): score value equals to '0'.
411            'cmi.score.raw => 0' => array('cmi.score.raw', '0'),
update-core.php https://bitbucket.org/stephenharris/stephenharris.git | PHP | 1,319 lines
857
858	$php_version    = phpversion();
859	$mysql_version  = $wpdb->db_version();
861	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
862	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
863	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
871	if ( !$mysql_compat && !$php_compat )
872		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
873	elseif ( !$php_compat )
873	elseif ( !$php_compat )
874		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
875	elseif ( !$mysql_compat )
948	if ( ! is_wp_error( $result ) ) {
949		if ( ! $wp_filesystem->copy( $from . $distro . 'wp-includes/version.php', $to . 'wp-includes/version.php', true /* overwrite */ ) ) {
950			$wp_filesystem->delete( $from, true );
update-core.php https://bitbucket.org/stephenharris/stephenharris.git | PHP | 661 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
437	<script type="text/javascript">
438	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
439	</script>
metar.php https://github.com/wrobel/horde-fw3.git | PHP | 476 lines
1<?php
2
3if ((@include_once 'Services/Weather.php') &&
4    !empty($GLOBALS['conf']['sql']['phptype'])) {
5    $block_name = _("Metar Weather");
12 *
13 * $Horde: horde/lib/Block/metar.php,v 1.22.10.11 2009-01-16 17:05:59 mrubinsk Exp $
14 *
37    {
38        if (!@include_once 'Services/Weather.php') {
39            Horde::logMessage('The metar block will not work without Services_Weather from PEAR. Run pear install Services_Weather.',
51            // Get locations from the database.
52            require_once 'DB.php';
53            $db = &DB::connect($conf['sql']);
58            // Set DB portability options.
59            switch ($db->phptype) {
60            case 'mssql':
update-core.php https://github.com/scottbale/kirkwoodcoc.git | PHP | 1,353 lines
891
892	$php_version    = phpversion();
893	$mysql_version  = $wpdb->db_version();
895	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
896	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
897	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
905	if ( !$mysql_compat && !$php_compat )
906		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
907	elseif ( !$php_compat )
907	elseif ( !$php_compat )
908		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
909	elseif ( !$mysql_compat )
982	if ( ! is_wp_error( $result ) ) {
983		if ( ! $wp_filesystem->copy( $from . $distro . 'wp-includes/version.php', $to . 'wp-includes/version.php', true /* overwrite */ ) ) {
984			$wp_filesystem->delete( $from, true );
Validator.php https://gitlab.com/BenasPaulikas/azuolynas.git | PHP | 366 lines
1<?php
2/**
128    /**
129     * @var callable a PHP callable that replaces the default implementation of [[isEmpty()]].
130     * If not set, [[isEmpty()]] will be used to check if a value is empty. The signature
133     */
134    public $isEmpty;
135    /**
135    /**
136     * @var callable a PHP callable whose return value determines whether this validator should be applied.
137     * The signature of the callable should be `function ($model, $attribute)`, where `$model` and `$attribute`
234            $skip = $this->skipOnError && $model->hasErrors($attribute)
235                || $this->skipOnEmpty && $this->isEmpty($model->$attribute);
236            if (!$skip) {
352     * Checks if the given value is empty.
353     * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
354     * Note that this method is different from PHP empty(). It will return false when the value is 0.
update-core.php https://gitlab.com/bernalesjasper/Auto-repair.git | PHP | 659 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
435	<script type="text/javascript">
436	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
437	</script>
update-core.php https://gitlab.com/bernalesjasper/Auto-repair.git | PHP | 1,188 lines
824
825	$php_version    = phpversion();
826	$mysql_version  = $wpdb->db_version();
828	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
829	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
830	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
838	if ( !$mysql_compat && !$php_compat )
839		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
840	elseif ( !$php_compat )
840	elseif ( !$php_compat )
841		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
842	elseif ( !$mysql_compat )
913	if ( ! is_wp_error( $result ) ) {
914		if ( ! $wp_filesystem->copy( $from . $distro . 'wp-includes/version.php', $to . 'wp-includes/version.php', true /* overwrite */ ) ) {
915			$wp_filesystem->delete( $from, true );
update-core.php https://gitlab.com/daigiangaitu91/wordpress.git | PHP | 659 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="http://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
435	<script type="text/javascript">
436	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
437	</script>
update-core.php https://gitlab.com/daigiangaitu91/wordpress.git | PHP | 1,188 lines
824
825	$php_version    = phpversion();
826	$mysql_version  = $wpdb->db_version();
828	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
829	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
830	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
838	if ( !$mysql_compat && !$php_compat )
839		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
840	elseif ( !$php_compat )
840	elseif ( !$php_compat )
841		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
842	elseif ( !$mysql_compat )
913	if ( ! is_wp_error( $result ) ) {
914		if ( ! $wp_filesystem->copy( $from . $distro . 'wp-includes/version.php', $to . 'wp-includes/version.php', true /* overwrite */ ) ) {
915			$wp_filesystem->delete( $from, true );
update-core.php https://gitlab.com/damith322/mtsmet.git | PHP | 661 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
437	<script type="text/javascript">
438	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
439	</script>
update-core.php https://gitlab.com/dinhkk/Pinotage.git | PHP | 661 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
437	<script type="text/javascript">
438	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
439	</script>
update-core.php https://gitlab.com/duban-alexei/WordPress.git | PHP | 693 lines
63		} else {
64			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
65			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
70			if ( !$mysql_compat && !$php_compat )
71				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
72			elseif ( !$php_compat )
72			elseif ( !$php_compat )
73				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
74			elseif ( !$mysql_compat )
170				'version'       => $wp_version . '.1.next.minor',
171				'php_version'   => $required_php_version,
172				'mysql_version' => $required_mysql_version,
463	<script type="text/javascript">
464	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
465	</script>
update-core.php https://gitlab.com/eita/encontre-consumo-responsavel.git | PHP | 661 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
437	<script type="text/javascript">
438	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
439	</script>
Validator.php https://gitlab.com/hostingvk4/yii2.git | PHP | 368 lines
1<?php
2/**
130    /**
131     * @var callable a PHP callable that replaces the default implementation of [[isEmpty()]].
132     * If not set, [[isEmpty()]] will be used to check if a value is empty. The signature
135     */
136    public $isEmpty;
137    /**
137    /**
138     * @var callable a PHP callable whose return value determines whether this validator should be applied.
139     * The signature of the callable should be `function ($model, $attribute)`, where `$model` and `$attribute`
236            $skip = $this->skipOnError && $model->hasErrors($attribute)
237                || $this->skipOnEmpty && $this->isEmpty($model->$attribute);
238            if (!$skip) {
354     * Checks if the given value is empty.
355     * A value is considered empty if it is null, an empty array, or an empty string.
356     * Note that this method is different from PHP empty(). It will return false when the value is 0.
Validator.php https://gitlab.com/hostingvk4/hostingvk4.git | PHP | 366 lines
1<?php
2/**
128    /**
129     * @var callable a PHP callable that replaces the default implementation of [[isEmpty()]].
130     * If not set, [[isEmpty()]] will be used to check if a value is empty. The signature
133     */
134    public $isEmpty;
135    /**
135    /**
136     * @var callable a PHP callable whose return value determines whether this validator should be applied.
137     * The signature of the callable should be `function ($model, $attribute)`, where `$model` and `$attribute`
234            $skip = $this->skipOnError && $model->hasErrors($attribute)
235                || $this->skipOnEmpty && $this->isEmpty($model->$attribute);
236            if (!$skip) {
352     * Checks if the given value is empty.
353     * A value is considered empty if it is null, an empty array, or the trimmed result is an empty string.
354     * Note that this method is different from PHP empty(). It will return false when the value is 0.
update-core.php https://gitlab.com/hunglion1368/wordpress-boilerplate.git | PHP | 661 lines
53		} else {
54			$php_compat     = version_compare( $php_version, $update->php_version, '>=' );
55			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
60			if ( !$mysql_compat && !$php_compat )
61				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $update->current, $update->php_version, $update->mysql_version, $php_version, $mysql_version );
62			elseif ( !$php_compat )
62			elseif ( !$php_compat )
63				$message = sprintf( __('You cannot update because <a href="https://codex.wordpress.org/Version_%1$s">WordPress %1$s</a> requires PHP version %2$s or higher. You are running version %3$s.'), $update->current, $update->php_version, $php_version );
64			elseif ( !$mysql_compat )
155				'version'       => $wp_version . '.1.next.minor',
156				'php_version'   => $required_php_version,
157				'mysql_version' => $required_mysql_version,
437	<script type="text/javascript">
438	window.location = '<?php echo self_admin_url( 'about.php?updated' ); ?>';
439	</script>
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21