PageRenderTime 19066ms queryFilters 0ms Sphinxql 918ms app.CodeModel.GetByIds 1663ms findMatchingLines 34ms GetByIds 1697ms meta 0ms repositoryFilters 14ms languageFilters 10ms sourceFilters 4ms

421,407 results for 'php empty repo:nikic/PHP-Parser' (19066 ms)

Source

Language

Repository

AkActionController.php https://repo.or.cz/akelos.git | PHP | 2,846 lines
1439        return !empty($options['layout']) ||
1440        (empty($options['text']) && empty($options['file']) && empty($options['inline']) && empty($options['partial']) && empty($options['nothing'])) &&
1441        !$this->_isTemplateExemptFromLayout($this->_getDefaultTemplateName(empty($options['action']) ? $options['template'] : $options['action']));
2057    *   display.tpl
2058    *     <?php if($flash['notice']) : ?><div class='notice'><?php echo $flash['notice'] ?></div><?php endif; ?>
2059    *
2355    {
2356        return (!empty($this->ssl_for_all_actions) && empty($this->_ssl_allowed_actions)) ||
2357        (!empty($this->_ssl_allowed_actions) && is_array($this->_ssl_allowed_actions) && isset($this->_action_name) ?
2771        return
2772        empty($this->Request->env['PHP_AUTH_USER']) ? (
2773        empty($this->Request->env['HTTP_AUTHORIZATION']) ? (
2780        ) : $this->Request->env['HTTP_AUTHORIZATION']
2781        ) : array($this->Request->env['PHP_AUTH_USER'], $this->Request->env['PHP_AUTH_PW']);
2782    }
card.php git://github.com/Dolibarr/dolibarr.git | PHP | 883 lines
290	$newlang='';
291	if ($conf->global->MAIN_MULTILANGS && empty($newlang) && ! empty($_REQUEST['lang_id'])) $newlang=$_REQUEST['lang_id'];
292	if ($conf->global->MAIN_MULTILANGS && empty($newlang)) $newlang=$object->thirdparty->default_lang;
394
395	if (empty($conf->societe->enabled) || empty($conf->global->DONATION_USE_THIRDPARTIES))
396	{
534
535    if ($object->socid && !empty($conf->societe->enabled) && !empty($conf->global->DONATION_USE_THIRDPARTIES)) {
536        $company = new Societe($db);
636
637	$linkback = '<a href="'.DOL_URL_ROOT.'/don/list.php'.(!empty($socid) ? '?socid='.$socid : '').'">'.$langs->trans("BackToList").'</a>';
638
867	// Show online payment link
868	$useonlinepayment = (!empty($conf->paypal->enabled) || !empty($conf->stripe->enabled) || !empty($conf->paybox->enabled));
869
v1.php https://github.com/forzapiri/dashboard.git | PHP | 1,612 lines
237/**
238 * Error code when a php5 package is packaged in php4 (analysis doesn't work)
239 */
1043                PEAR_PACKAGEFILE_ERROR_PHP5 =>
1044                    'Error, PHP5 token encountered in %file%, analysis should be in PHP5',
1045                PEAR_PACKAGEFILE_ERROR_FILE_NOTFOUND =>
1151                }
1152                if ($d['type'] == 'php' && !empty($d['name'])) {
1153                    $this->_validateWarning(PEAR_PACKAGEFILE_ERROR_DEPNAME_IGNORED,
1154                        array('index' => $i, 'name' => $d['name']));
1155                } elseif ($d['type'] != 'php' && empty($d['name'])) {
1156                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPNAME,
1158                }
1159                if ($d['type'] == 'php' && empty($d['version'])) {
1160                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPPHPVERSION,
v1.php https://github.com/jlduran/BAPS2.git | PHP | 1,618 lines
16 * @copyright  1997-2006 The PHP Group
17 * @license    http://www.php.net/license/3_0.txt  PHP License 3.0
18 * @version    CVS: $Id: v1.php,v 1.73 2007/05/10 00:00:38 cellog Exp $
1049                PEAR_PACKAGEFILE_ERROR_PHP5 =>
1050                    'Error, PHP5 token encountered in %file%, analysis should be in PHP5',
1051                PEAR_PACKAGEFILE_ERROR_FILE_NOTFOUND =>
1157                }
1158                if ($d['type'] == 'php' && !empty($d['name'])) {
1159                    $this->_validateWarning(PEAR_PACKAGEFILE_ERROR_DEPNAME_IGNORED,
1160                        array('index' => $i, 'name' => $d['name']));
1161                } elseif ($d['type'] != 'php' && empty($d['name'])) {
1162                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPNAME,
1164                }
1165                if ($d['type'] == 'php' && empty($d['version'])) {
1166                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPPHPVERSION,
v1.php https://github.com/Magrath/Centrifuge.git | PHP | 1,618 lines
16 * @copyright  1997-2008 The PHP Group
17 * @license    http://www.php.net/license/3_0.txt  PHP License 3.0
18 * @version    CVS: $Id: v1.php,v 1.74 2008/01/03 20:26:36 cellog Exp $
1049                PEAR_PACKAGEFILE_ERROR_PHP5 =>
1050                    'Error, PHP5 token encountered in %file%, analysis should be in PHP5',
1051                PEAR_PACKAGEFILE_ERROR_FILE_NOTFOUND =>
1157                }
1158                if ($d['type'] == 'php' && !empty($d['name'])) {
1159                    $this->_validateWarning(PEAR_PACKAGEFILE_ERROR_DEPNAME_IGNORED,
1160                        array('index' => $i, 'name' => $d['name']));
1161                } elseif ($d['type'] != 'php' && empty($d['name'])) {
1162                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPNAME,
1164                }
1165                if ($d['type'] == 'php' && empty($d['version'])) {
1166                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPPHPVERSION,
v1.php https://github.com/0xshyam/efront_open_source.git | PHP | 1,612 lines
237/**
238 * Error code when a php5 package is packaged in php4 (analysis doesn't work)
239 */
1043                PEAR_PACKAGEFILE_ERROR_PHP5 =>
1044                    'Error, PHP5 token encountered in %file%, analysis should be in PHP5',
1045                PEAR_PACKAGEFILE_ERROR_FILE_NOTFOUND =>
1151                }
1152                if ($d['type'] == 'php' && !empty($d['name'])) {
1153                    $this->_validateWarning(PEAR_PACKAGEFILE_ERROR_DEPNAME_IGNORED,
1154                        array('index' => $i, 'name' => $d['name']));
1155                } elseif ($d['type'] != 'php' && empty($d['name'])) {
1156                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPNAME,
1158                }
1159                if ($d['type'] == 'php' && empty($d['version'])) {
1160                    $this->_validateError(PEAR_PACKAGEFILE_ERROR_NO_DEPPHPVERSION,
update-core.php git://github.com/markjaquith/WordPress.git | PHP | 952 lines
60	$form_action   = 'update-core.php?action=do-core-upgrade';
61	$php_version   = phpversion();
62	$mysql_version = $wpdb->db_version();
72		} else {
73			$php_compat = version_compare( $php_version, $update->php_version, '>=' );
74			if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) ) {
109				$message = sprintf(
110					/* translators: 1: URL to WordPress release notes, 2: WordPress version number, 3: Minimum required PHP version number, 4: Current PHP version number. */
111					__( 'You cannot update because <a href="%1$s">WordPress %2$s</a> requires PHP version %3$s or higher. You are running version %4$s.' ),
237				'version'       => $wp_version . '.1.next.minor',
238				'php_version'   => $required_php_version,
239				'mysql_version' => $required_mysql_version,
361
362		$requires_php   = isset( $plugin_data->update->requires_php ) ? $plugin_data->update->requires_php : null;
363		$compatible_php = is_php_version_compatible( $requires_php );
common.php https://exult.svn.sourceforge.net/svnroot/exult | PHP | 422 lines
1<?php
2  if ( defined( "_COMMON_PHP" ) ) return;
33  // handle configs that have register_globals turned off.
34  // we use $PHP_SELF as the test since it should always be there.
35  // We might need to consider not using globals soon.
35  // We might need to consider not using globals soon.
36  if(!isset($PHP_SELF)) {
37     include ("./include/register_globals.php");
147
148  // passed to array_walk in read.php and list.php
149  // **TODO: replace using array_flip
315  // include abstraction layer and check if its defined
316  if(!defined("PHORUM_ADMIN") && (empty($PHORUM["dbtype"]) || !file_exists("./db/$PHORUM[dbtype].php"))){
317    echo "<html><head><title>Phorum Error</title></head><body>Something is wrong.  You need to edit common.php and select a database.</body></html>";
406      while($plugindirname = readdir($dir)) {
407        if($plugindirname[0] != "." && @file_exists("./plugin/$plugindirname/plugin.php") && !empty($PHORUM["plugins"][$plugindirname])){
408          include("./plugin/$plugindirname/plugin.php");
errors.html http://mc-goog-visualization.googlecode.com/svn/trunk/ | HTML | 89 lines
11						<a href="#Post-parsing">Post-parsing</a><br>
12<a href="#Empty.php">Empty.php</a><br>
13<a href="#Group.php">Group.php</a><br>
13<a href="#Group.php">Group.php</a><br>
14<a href="#Literal.php">Literal.php</a><br>
15<a href="#NOrMore.php">NOrMore.php</a><br>
15<a href="#NOrMore.php">NOrMore.php</a><br>
16<a href="#OneOf.php">OneOf.php</a><br>
17<a href="#Parser.php">Parser.php</a><br>
17<a href="#Parser.php">Parser.php</a><br>
18<a href="#Recursive.php">Recursive.php</a><br>
19<a href="#Regex.php">Regex.php</a><br>
28<b>Warning on line 28</b> - no @package tag was used in a DocBlock for class MC_Parser_Def<br>
29<a name="Empty.php"></a>
30<h1>Empty.php</h1>
footer.inc.php http://iprn.googlecode.com/svn/trunk/ | PHP | 223 lines
1<?php
2/* vim: set expandtab sw=4 ts=4 sts=4: */
43 * @uses    file_exists()
44 * @version $Id: footer.inc.php 11986 2008-11-24 11:05:40Z nijel $
45 * @package phpMyAdmin
46 */
47if (! defined('PHPMYADMIN')) {
48    exit;
53 */
54require_once './libraries/relation.lib.php';
55
55
56if (! PMA_isValid($_REQUEST['no_history']) && empty($GLOBALS['error_message'])
57 && ! empty($GLOBALS['sql_query'])) {
200// profiling deactivated due to licensing issues
201if (! empty($GLOBALS['cfg']['DBG']['php'])
202 && ! empty($GLOBALS['cfg']['DBG']['profile']['enable'])) {
CAccessRule.js git://github.com/phpnode/YiiJS.git | JavaScript | 195 lines
97Yii.CAccessRule.prototype.isActionMatched = function (action) {
98		return php.empty(this.actions) || php.in_array(action.getId().toLowerCase(),this.actions);
99	};
104Yii.CAccessRule.prototype.isControllerMatched = function (controller) {
105		return php.empty(this.controllers) || php.in_array(controller.getId().toLowerCase(),this.controllers);
106	};
141		var i, role;
142		if(php.empty(this.roles)) {
143			return true;
161		var i, rule, pos;
162		if(php.empty(this.ips)) {
163			return true;
180Yii.CAccessRule.prototype.isVerbMatched = function (verb) {
181		return php.empty(this.verbs) || php.in_array(verb.toLowerCase(),this.verbs);
182	};
CMenu.js git://github.com/phpnode/YiiJS.git | JavaScript | 292 lines
1/*global Yii, php, $, jQuery, alert, clearInterval, clearTimeout, document, event, frames, history, Image, location, name, navigator, Option, parent, screen, setInterval, setTimeout, window, XMLHttpRequest */
2/**
80 * @var {String} the CSS class to be appended to the active menu item. Defaults to 'active'.
81 * If empty, the CSS class of menu items will not be changed.
82 */
96/**
97 * @var {Boolean} whether to hide empty menu items. An empty menu item is one whose 'url' option is not
98 * set and which doesn't contain visible child menu items. Defaults to true.
179			if(classVar!==[]) {
180				if(php.empty(options['class'])) {
181					options['class']=classVar.join(' ');
245					items[i].items=this.normalizeItems(item.items,route,hasActiveChild);
246					if(php.empty(items[i].items) && this.hideEmptyItems) {
247						delete items[i].items;
275		var nameValue, name, value;
276		if(item.url !== undefined && Object.prototype.toString.call(item.url) === '[object Array]' && !php.strcasecmp(php.trim(item.url[0],'/'),route)) {
277			
CSecurityManager.js git://github.com/phpnode/YiiJS.git | JavaScript | 246 lines
1/*global Yii, php, sjcl, $, jQuery, alert, clearInterval, clearTimeout, document, event, frames, history, Image, location, name, navigator, Option, parent, screen, setInterval, setTimeout, window, XMLHttpRequest */
2/**
27 * @originalAuthor Qiang Xue <qiang.xue@gmail.com>
28 * @version $Id: CSecurityManager.php 3001 2011-02-24 16:42:44Z alexander.makarow $
29 * @package system.base
60Yii.CSecurityManager.prototype.generateRandomKey = function () {
61		return php.sprintf('%08x%08x%08x%08x',php.mt_rand(),php.mt_rand(),php.mt_rand(),php.mt_rand());
62	};
85 * @param {String} value the key used to generate HMAC
86 * @throws {Yii.CException} if the key is empty
87 */
88Yii.CSecurityManager.prototype.setValidationKey = function (value) {
89		if(!php.empty(value)) {
90			this._validationKey=value;
121Yii.CSecurityManager.prototype.setEncryptionKey = function (value) {
122		if(!php.empty(value)) {
123			this._encryptionKey=value;
footer.inc.php git://github.com/jyr/MNPP.git | PHP | 223 lines
1<?php
2/* vim: set expandtab sw=4 ts=4 sts=4: */
44 * @version $Id$
45 * @package phpMyAdmin
46 */
46 */
47if (! defined('PHPMYADMIN')) {
48    exit;
53 */
54require_once './libraries/relation.lib.php';
55
55
56if (! PMA_isValid($_REQUEST['no_history']) && empty($GLOBALS['error_message'])
57 && ! empty($GLOBALS['sql_query'])) {
200// profiling deactivated due to licensing issues
201if (! empty($GLOBALS['cfg']['DBG']['php'])
202 && ! empty($GLOBALS['cfg']['DBG']['profile']['enable'])) {
update-core.php https://git01.codeplex.com/officialwp | PHP | 880 lines
1<?php
2/**
26'wp-admin/import-mt.php',
27'wp-admin/import-rss.php',
28'wp-admin/import-textpattern.php',
644
645	$php_version    = phpversion();
646	$mysql_version  = $wpdb->db_version();
648	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
649	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
650	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
658	if ( !$mysql_compat && !$php_compat )
659		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
660	elseif ( !$php_compat )
660	elseif ( !$php_compat )
661		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
662	elseif ( !$mysql_compat )
alipay.php https://bitbucket.org/johnroyer/phpwind8.7.git | PHP | 132 lines
1<?php
2require_once('global.php');
3require_once(R_P.'require/posthost.php');
4//* include_once pwCache::getPath(D_P.'data/bbscache/ol_config.php');
5pwCache::getData(D_P.'data/bbscache/ol_config.php');
7S::gp(array('action','out_trade_no','trade_status','buyer_email','notify_id','extra_common_param'));
8$ret_url = $extra_common_param ? getExtra($extra_common_param) : 'userpay.php';
9!empty($_POST) && $_GET = $_POST;
11
12if ($action || empty($ol_alipaykey) || empty($ol_alipaypartnerID)) {
13	$ol_alipaypartnerID = '2088301270630891';
24	}
25	$veryfy_result1 = PostHost("http://pay.phpwind.net/pay/alipay_notify.php", $url, 'POST');
26} else {
41
42if (empty($action)) {
43
feed-wp-config.php https://bitbucket.org/jcsarda/wordpress-dotcloud-deployable.git | PHP | 117 lines
1#!/usr/bin/env php
2<?php
14define("WP_CONFIG_FILE_NAME", dirname(__FILE__) . '/../wp-config.php');
15define("WP_CONFIG_sample_FILE_NAME", dirname(__FILE__) . '/../wp-config-sample.php');
16// the name of the database that will be created for wordpress
25$json = @file_get_contents(ENVIRONMENT_FILE_NAME);
26if (empty($json)) {
27    die(MSG_PREFIX . "Error: Can't read environment.json file.\n");
31$environment = @json_decode($json);
32if (empty($environment)) {
33    die(MSG_PREFIX . "Error: Content of environment.json is not valid json.\n");
53    if (empty($content)) {
54        echo MSG_PREFIX . "File wp-config.php not found (looking at: " . WP_CONFIG_FILE_NAME . "). Trying to find wp-config-sample.php\n";
55    }
57} else {
58    echo MSG_PREFIX . "File wp-config.php empty (looking at: " . WP_CONFIG_FILE_NAME . "). Trying to find wp-config-sample.php\n";
59}
footer.inc.php https://bitbucket.org/kucing2k/ediassoc.git | PHP | 222 lines
1<?php
2/* vim: set expandtab sw=4 ts=4 sts=4: */
44 * @version $Id$
45 * @package phpMyAdmin
46 */
46 */
47if (! defined('PHPMYADMIN')) {
48    exit;
53 */
54require_once './libraries/relation.lib.php';
55
55
56if (! PMA_isValid($_REQUEST['no_history']) && empty($GLOBALS['error_message'])
57 && ! empty($GLOBALS['sql_query'])) {
200// profiling deactivated due to licensing issues
201if (! empty($GLOBALS['cfg']['DBG']['php'])
202 && ! empty($GLOBALS['cfg']['DBG']['profile']['enable'])) {
PackageManagerDisplay.php https://bitbucket.org/cviolette/sugarcrm.git | PHP | 618 lines
1<?php
2/*********************************************************************************
41require_once('include/ytree/Tree.php');
42require_once('include/ytree/Node.php');
43require_once('ModuleInstall/PackageManager/ListViewPackages.php');
75        $error_html = "";
76		if(!empty($mi_errors)){
77			$error_html = "<tr><td><span>";
212        }
213        if($form_action == 'install.php' && (empty($releases) || count($releases['packages']) == 0)){
214        	//return false;
237    	$output = "<div id='login_panel'><div class='hd'><b>".$mod_strings['HDR_LOGIN_PANEL']."</b></div>";
238        $output .= "<div class='bd'><form><table><tr><td>".$mod_strings['LBL_USERNAME']."</td><td><input type='text' name='login_panel_username' id='login_panel_username' value='".$credentials['username']."'></td><td><a href='http://www.sugarcrm.com/crm/index.php?option=com_registration&task=register' target='blank'>".$mod_strings['LNK_NEW_ACCOUNT']."</a></td>";
239
530            $credentials = PackageManager::getCredentials();
531            if(empty($credentials['username']) || empty($credentials['password'])){
532            	//$header_text = "<font color='red'><b>".$mod_strings['ERR_CREDENTIALS_MISSING']."</b></font>";
update-core.php https://bitbucket.org/dkrzos/phc.git | PHP | 881 lines
1<?php
2/**
26'wp-admin/import-mt.php',
27'wp-admin/import-rss.php',
28'wp-admin/import-textpattern.php',
646
647	$php_version    = phpversion();
648	$mysql_version  = $wpdb->db_version();
650	$development_build = ( false !== strpos( $old_wp_version . $wp_version, '-' )  ); // a dash in the version indicates a Development release
651	$php_compat     = version_compare( $php_version, $required_php_version, '>=' );
652	if ( file_exists( WP_CONTENT_DIR . '/db.php' ) && empty( $wpdb->is_mysql ) )
660	if ( !$mysql_compat && !$php_compat )
661		return new WP_Error( 'php_mysql_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher and MySQL version %3$s or higher. You are running PHP version %4$s and MySQL version %5$s.'), $wp_version, $required_php_version, $required_mysql_version, $php_version, $mysql_version ) );
662	elseif ( !$php_compat )
662	elseif ( !$php_compat )
663		return new WP_Error( 'php_not_compatible', sprintf( __('The update cannot be installed because WordPress %1$s requires PHP version %2$s or higher. You are running version %3$s.'), $wp_version, $required_php_version, $php_version ) );
664	elseif ( !$mysql_compat )
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21