PageRenderTime 26ms CodeModel.GetById 0ms RepoModel.GetById 1ms app.codeStats 0ms

/jEdit/tags/jedit-4-1-pre5/jedit.spec

#
Unknown | 75 lines | 55 code | 20 blank | 0 comment | 0 complexity | de3674f8b393af8a583dc92622acd20d MD5 | raw file
Possible License(s): BSD-3-Clause, AGPL-1.0, Apache-2.0, LGPL-2.0, LGPL-3.0, GPL-2.0, CC-BY-SA-3.0, LGPL-2.1, GPL-3.0, MPL-2.0-no-copyleft-exception, IPL-1.0
  1. ###
  2. ### RPM spec file for jEdit
  3. ###
  4. ### To create the RPM, put the source tarball in the RPM SOURCES
  5. ### directory, and invoke:
  6. ### rpm -ba jedit.spec
  7. ### You will need to have ant, xsltproc, and DocBook-XML 4.1.2 installed
  8. ### for this to work.
  9. Summary: Programmer's text editor written in Java
  10. Name: jedit
  11. Version: 4.1
  12. Release: 1
  13. # REMIND: bump this with each RPM
  14. Serial: 30
  15. Copyright: GPL
  16. Group: Applications/Editors
  17. Source0: http://prdownloads.sourceforge.net/jedit/jedit41source.tar.gz
  18. Source1: jedit.sh.in
  19. URL: http://www.jedit.org
  20. Vendor: Slava Pestov <slava@jedit.org>
  21. Packager: Slava Pestov <slava@jedit.org>
  22. BuildArch: noarch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. jEdit is an Open Source, cross platform text editor written in Java. It
  26. has an extensive feature set that includes syntax highlighting, auto indent,
  27. folding, word wrap, abbreviation expansion, multiple clipboards, powerful search
  28. and replace, and much more.
  29. Futhermore, jEdit is extremely customizable, and extensible, using either macros
  30. written in the BeanShell scripting language, or plugins written in Java.
  31. jEdit requires Java 2 version 1.3.
  32. %prep
  33. %setup -n jEdit
  34. %build
  35. export CLASSPATH="."
  36. ant docs-html-xsltproc dist
  37. # Build LatestVersion.jar
  38. (cd jars/LatestVersion && ant)
  39. # Build QuickNotepad.jar
  40. (cd jars/QuickNotepad && ant)
  41. # Create installer filelists
  42. sh installer/mk_filelist.sh
  43. %install
  44. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  45. export CLASSPATH="."
  46. java installer.Install auto $RPM_BUILD_ROOT%{_datadir}/jedit/%{version} \
  47. $RPM_BUILD_ROOT%{_bindir}
  48. sed -e "s^@JEDIT_HOME@^"%{_datadir}"/jedit/"%{version}"^g" < %{SOURCE1} > \
  49. $RPM_BUILD_ROOT%{_bindir}/jedit
  50. chmod +x $RPM_BUILD_ROOT%{_bindir}/jedit
  51. %clean
  52. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  53. %files
  54. %{_bindir}/jedit
  55. %{_datadir}/jedit/%{version}