PageRenderTime 14ms CodeModel.GetById 7ms app.highlight 5ms RepoModel.GetById 0ms app.codeStats 1ms

/jEdit/tags/jedit-4-0-pre5/jedit.spec

#
Unknown | 79 lines | 58 code | 21 blank | 0 comment | 0 complexity | 49a1f0f22f02ab3c0e4f1140cea4fbb2 MD5 | raw file
Possible License(s): BSD-3-Clause, AGPL-1.0, Apache-2.0, LGPL-2.0, LGPL-3.0, GPL-2.0, CC-BY-SA-3.0, LGPL-2.1, GPL-3.0, MPL-2.0-no-copyleft-exception, IPL-1.0
 1###
 2### RPM spec file for jEdit
 3###
 4
 5### To create the RPM, put the source tarball in the RPM SOURCES
 6### directory, and invoke:
 7
 8### rpm -ba jedit.spec
 9
10### You will need to have jmk, openjade and DocBook-XML 4.1.2 installed
11### for this to work.
12
13Summary: Programmer's text editor written in Java
14Name: jedit
15Version: 4.0pre4
16Release: 1
17# REMIND: bump this with each RPM
18Serial: 25
19Copyright: GPL
20Group: Applications/Editors
21Source0: http://prdownloads.sourceforge.net/jedit/jedit40pre4source.tar.gz
22Source1: jedit.sh.in
23URL: http://www.jedit.org
24Vendor: Slava Pestov <slava@jedit.org>
25Packager: Slava Pestov <slava@jedit.org>
26BuildArch: noarch
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
29%description
30jEdit is an Open Source, cross platform text editor written in Java. It
31has an extensive feature set that includes syntax highlighting, auto indent,
32folding, word wrap, abbreviation expansion, multiple clipboards, powerful search
33and replace, and much more.
34
35Futhermore, jEdit is extremely customizable, and extensible, using either macros
36written in the BeanShell scripting language, or plugins written in Java.
37
38jEdit requires Java 2 version 1.3.
39
40%prep
41%setup -n jEdit
42
43%build
44export CLASSPATH="."
45
46# Build docs
47ant docs-html-xsltproc
48
49# Build jedit.jar
50ant
51
52# Build LatestVersion.jar
53(cd jars/LatestVersion && ant)
54
55# Build QuickNotepad.jar
56(cd jars/QuickNotepad && ant)
57
58# Create installer filelists
59sh installer/mk_filelist.sh
60
61%install
62[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
63
64export CLASSPATH="."
65
66java installer.Install auto $RPM_BUILD_ROOT%{_datadir}/jedit/%{version} \
67	$RPM_BUILD_ROOT%{_bindir}
68
69sed -e "s^@JEDIT_HOME@^"%{_datadir}"/jedit/"%{version}"^g" < %{SOURCE1} > \
70	$RPM_BUILD_ROOT%{_bindir}/jedit
71
72chmod +x $RPM_BUILD_ROOT%{_bindir}/jedit
73
74%clean
75[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
76
77%files
78%{_bindir}/jedit
79%{_datadir}/jedit/%{version}