PageRenderTime 36ms CodeModel.GetById 9ms RepoModel.GetById 0ms app.codeStats 0ms

/jEdit/tags/jedit-4-0-pre5/jedit.spec

#
Unknown | 79 lines | 58 code | 21 blank | 0 comment | 0 complexity | 49a1f0f22f02ab3c0e4f1140cea4fbb2 MD5 | raw file
Possible License(s): BSD-3-Clause, AGPL-1.0, Apache-2.0, LGPL-2.0, LGPL-3.0, GPL-2.0, CC-BY-SA-3.0, LGPL-2.1, GPL-3.0, MPL-2.0-no-copyleft-exception, IPL-1.0
  1. ###
  2. ### RPM spec file for jEdit
  3. ###
  4. ### To create the RPM, put the source tarball in the RPM SOURCES
  5. ### directory, and invoke:
  6. ### rpm -ba jedit.spec
  7. ### You will need to have jmk, openjade and DocBook-XML 4.1.2 installed
  8. ### for this to work.
  9. Summary: Programmer's text editor written in Java
  10. Name: jedit
  11. Version: 4.0pre4
  12. Release: 1
  13. # REMIND: bump this with each RPM
  14. Serial: 25
  15. Copyright: GPL
  16. Group: Applications/Editors
  17. Source0: http://prdownloads.sourceforge.net/jedit/jedit40pre4source.tar.gz
  18. Source1: jedit.sh.in
  19. URL: http://www.jedit.org
  20. Vendor: Slava Pestov <slava@jedit.org>
  21. Packager: Slava Pestov <slava@jedit.org>
  22. BuildArch: noarch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. jEdit is an Open Source, cross platform text editor written in Java. It
  26. has an extensive feature set that includes syntax highlighting, auto indent,
  27. folding, word wrap, abbreviation expansion, multiple clipboards, powerful search
  28. and replace, and much more.
  29. Futhermore, jEdit is extremely customizable, and extensible, using either macros
  30. written in the BeanShell scripting language, or plugins written in Java.
  31. jEdit requires Java 2 version 1.3.
  32. %prep
  33. %setup -n jEdit
  34. %build
  35. export CLASSPATH="."
  36. # Build docs
  37. ant docs-html-xsltproc
  38. # Build jedit.jar
  39. ant
  40. # Build LatestVersion.jar
  41. (cd jars/LatestVersion && ant)
  42. # Build QuickNotepad.jar
  43. (cd jars/QuickNotepad && ant)
  44. # Create installer filelists
  45. sh installer/mk_filelist.sh
  46. %install
  47. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  48. export CLASSPATH="."
  49. java installer.Install auto $RPM_BUILD_ROOT%{_datadir}/jedit/%{version} \
  50. $RPM_BUILD_ROOT%{_bindir}
  51. sed -e "s^@JEDIT_HOME@^"%{_datadir}"/jedit/"%{version}"^g" < %{SOURCE1} > \
  52. $RPM_BUILD_ROOT%{_bindir}/jedit
  53. chmod +x $RPM_BUILD_ROOT%{_bindir}/jedit
  54. %clean
  55. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  56. %files
  57. %{_bindir}/jedit
  58. %{_datadir}/jedit/%{version}