PageRenderTime 173ms CodeModel.GetById 20ms RepoModel.GetById 1ms app.codeStats 0ms

/python-sqlalchemy.spec

#
Unknown | 328 lines | 239 code | 89 blank | 0 comment | 0 complexity | 3d2b714291089244bd00be42f7015c4a MD5 | raw file
  1. %if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %endif
  4. %if 0%{?fedora} > 12 || 0%{?rhel} > 6
  5. %global with_python3 1
  6. %endif
  7. %global srcname SQLAlchemy
  8. Name: python-sqlalchemy
  9. Version: 0.7.8
  10. Release: 2%{?dist}
  11. Summary: Modular and flexible ORM library for python
  12. Group: Development/Libraries
  13. License: MIT
  14. URL: http://www.sqlalchemy.org/
  15. Source0: http://pypi.python.org/packages/source/S/%{srcname}/%{srcname}-%{version}.tar.gz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: python2-devel
  18. %if 0%{?fedora} && 0%{?fedora} < 13
  19. BuildRequires: python-setuptools-devel >= 0.6c3
  20. %else
  21. BuildRequires: python-setuptools
  22. %endif
  23. BuildRequires: python-nose
  24. %if 0%{?with_python3}
  25. BuildRequires: python3-devel
  26. BuildRequires: python3-setuptools
  27. BuildRequires: python3-nose
  28. %endif
  29. %description
  30. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  31. high-level interface to SQL databases. Database and domain concepts are
  32. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  33. provides a powerful mapping layer that can work as automatically or as manually
  34. as you choose, determining relationships based on foreign keys or letting you
  35. define the join conditions explicitly, to bridge the gap between database and
  36. domain.
  37. This package includes the python 2 version of the module.
  38. %if 0%{?with_python3}
  39. %package -n python3-sqlalchemy
  40. Summary: Modular and flexible ORM library for python
  41. Group: Development/Libraries
  42. %description -n python3-sqlalchemy
  43. SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
  44. high-level interface to SQL databases. Database and domain concepts are
  45. decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
  46. provides a powerful mapping layer that can work as automatically or as manually
  47. as you choose, determining relationships based on foreign keys or letting you
  48. define the join conditions explicitly, to bridge the gap between database and
  49. domain.
  50. This package includes the python 3 version of the module.
  51. %endif # with_python3
  52. # Filter unnecessary dependencies
  53. %{?filter_setup:
  54. %filter_provides_in %{python_sitearch}.*\.so$
  55. %filter_provides_in %{python3_sitearch}.*\.so$
  56. %filter_setup
  57. }
  58. %prep
  59. %setup -q -n %{srcname}-%{version}
  60. %if 0%{?with_python3}
  61. rm -rf %{py3dir}
  62. cp -a . %{py3dir}
  63. %endif # with_python3
  64. %build
  65. CFLAGS="%{optflags}" %{__python} setup.py --with-cextensions build
  66. %if 0%{?with_python3}
  67. pushd %{py3dir}
  68. # Convert tests, examples, source to python3
  69. %{__python3} sa2to3.py --no-diffs -w lib test examples
  70. # Currently the cextension doesn't work with py3
  71. CFLAGS="%{optflags}" %{__python3} setup.py build
  72. popd
  73. %endif
  74. %install
  75. rm -rf %{buildroot}
  76. mkdir -p %{buildroot}%{python_sitelib}
  77. %{__python} setup.py --with-cextensions install --skip-build --root %{buildroot}
  78. %if 0%{?with_python3}
  79. pushd %{py3dir}
  80. mkdir -p %{buildroot}%{python3_sitelib}
  81. %{__python3} setup.py install --skip-build --root %{buildroot}
  82. popd
  83. %endif
  84. # remove unnecessary scripts for building documentation
  85. rm -rf doc/build
  86. %clean
  87. rm -rf %{buildroot}
  88. %check
  89. %{__python} ./sqla_nose.py
  90. %if 0%{?with_python3}
  91. pushd %{py3dir}
  92. %{__python3} ./sqla_nose.py
  93. popd
  94. %endif
  95. %files
  96. %defattr(-,root,root,-)
  97. %doc README.rst LICENSE PKG-INFO CHANGES doc examples
  98. %{python_sitearch}/*
  99. %if 0%{?with_python3}
  100. %files -n python3-sqlalchemy
  101. %defattr(-,root,root,-)
  102. %doc LICENSE PKG-INFO doc examples
  103. %{python3_sitelib}/*
  104. %endif # with_python3
  105. %changelog
  106. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.8-2
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  108. * Mon Jun 18 2012 Nils Philippsen <nils@redhat.com> - 0.7.8-1
  109. - Upstream bugfix release
  110. * Tue May 15 2012 Nils Philippsen <nils@redhat.com> - 0.7.7-1
  111. - Upstream bugfix release
  112. * Tue Mar 20 2012 Nils Philippsen <nils@redhat.com> - 0.7.6-1
  113. - Upstream bugfix release
  114. * Mon Jan 30 2012 Nils Philippsen <nils@redhat.com> - 0.7.5-1
  115. - Upstream bugfix release
  116. - package README.rst instead of README as documentation
  117. * Tue Jan 10 2012 Nils Philippsen <nils@redhat.com> - 0.7.3-2
  118. - rebuild for gcc 4.7
  119. * Mon Oct 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.3-1
  120. - Upstream bugfix release
  121. * Mon Aug 1 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.7.2-1
  122. - Upstream bugfix release
  123. * Mon Jun 06 2011 Nils Philippsen <nils@redhat.com> - 0.7.1-1
  124. - 0.7.1 Upstream release
  125. - no need to fix examples/dynamic_dict/dynamic_dict.py anymore
  126. - use sqla_nose.py to fix %%check
  127. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.6-2
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  129. * Mon Jan 17 2011 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.6-1
  130. - 0.6.6 Upstream release
  131. * Fri Dec 3 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-1
  132. - 0.6.5 Upstream release
  133. * Wed Sep 29 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-2
  134. - Filter out the C extensions from provides
  135. * Tue Sep 07 2010 Luke Macken <lmacken@redhat.com> - 0.6.4-1
  136. - 0.6.4 upstream release
  137. * Mon Aug 23 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.3-1
  138. - 0.6.3 upstream release
  139. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com>
  140. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  141. * Thu Jun 24 2010 Nils Philippsen <nils@redhat.com> - 0.6.1-1
  142. - 0.6.1 upstream release
  143. * Tue Apr 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.4.beta3
  144. - Build beta3
  145. * Fri Mar 19 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.3.beta2
  146. - Build beta2 with cextension
  147. * Sun Mar 7 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.2.beta1
  148. - Build python3 package
  149. * Tue Mar 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6-0.1.beta1
  150. - 0.6 beta1 upstream release
  151. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-3
  152. - One last cleanup
  153. * Tue Feb 2 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-2
  154. - just some cleanups to older styles of building packages.
  155. * Mon Feb 1 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.8-1
  156. - Upstream bugfix release 0.5.8
  157. * Fri Aug 14 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.5-2
  158. - Upstream bugfix release 0.5.5
  159. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.4-2.p2
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  161. * Fri Jun 12 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.4-1.p2
  162. - Upstream bugfix release 0.5.4p2.
  163. * Thu Apr 16 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.3-1
  164. - Upstream bugfix release.
  165. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-2
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  167. * Wed Feb 11 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.2-1
  168. - Update to 0.5.2
  169. * Wed Jan 21 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5.1-1
  170. - Update to 0.5.1.
  171. * Mon Dec 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.5-0.1.rc4
  172. - Update to 0.5.0rc4 which works with the new pysqlite
  173. - And update test cases to work with the new pysqlite
  174. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.7-2
  175. - Rebuild for Python 2.6
  176. * Sun Jul 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.7-1
  177. - Update to 0.4.7.
  178. * Sun Jun 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.6-1
  179. - Update to 0.4.6.
  180. * Tue Apr 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.5-1
  181. - Update to 0.4.5.
  182. * Fri Feb 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.3-1
  183. - Update to 0.4.3.
  184. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.2-1.p3
  185. - Update to 0.4.2p3.
  186. * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.1-1
  187. - Update to 0.4.1.
  188. * Wed Oct 17 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.0-1
  189. - SQLAlchemy-0.4.0 final
  190. - Run the testsuite
  191. * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> 0.4.0-0.4.beta6
  192. - SQLAlchemy-0.4.0beta6
  193. * Tue Sep 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta5
  194. - Update to 0.4beta5.
  195. * Fri Sep 06 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta4
  196. - setuptools has been fixed.
  197. * Fri Aug 31 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.3.beta4
  198. - setuptools seems to be broken WRT having an active and inactive version
  199. of an egg. Have to make both versions inactive and manually setup a copy
  200. that can be started via import. (Necessary for the sqlalchemy0.3 compat
  201. package.)
  202. * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.2.beta4
  203. - Modify setuptools to handle the -devel subpackage split in F-8.
  204. * Mon Aug 27 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.0-0.1.beta4
  205. - Update to 0.4 beta4.
  206. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-2
  207. - Remove python-abi Requires. This is automatic since FC4+.
  208. * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-1
  209. - Update to new upstream version 0.3.10
  210. * Fri Mar 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.6-1
  211. - Update to new upstream version 0.3.6
  212. * Sat Mar 10 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.5-1
  213. - Update to new upstream version 0.3.5
  214. - Simplify the files listing
  215. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-2
  216. - Remember to upload the source tarball to the lookaside cache.
  217. * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-1
  218. - Update to new upstream version 0.3.4
  219. * Mon Jan 01 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.3-1
  220. - Update to new upstream version 0.3.3
  221. * Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-2
  222. - Bump and rebuild for python 2.5 on devel.
  223. - BuildRequire: python-devel as a header is missing otherwise.
  224. * Fri Nov 24 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-1
  225. - Update to new upstream version 0.3.1
  226. * Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 0.2.7-2
  227. - Rebuild for FC6
  228. * Thu Aug 17 2006 Shahms E. King <shahms@shahms.com> 0.2.7-1
  229. - Update to new upstream version
  230. * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.2.6-2
  231. - Include, don't ghost .pyo files per new guidelines
  232. * Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 0.2.6-1
  233. - Update to new upstream version
  234. * Fri Jul 07 2006 Shahms E. King <shahms@shahms.com> 0.2.4-1
  235. - Update to new upstream version
  236. * Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.2.3-1
  237. - Update to new upstream version
  238. * Wed May 31 2006 Shahms E. King <shahms@shahms.com> 0.2.1-1
  239. - Update to new upstream version