PageRenderTime 50ms CodeModel.GetById 24ms RepoModel.GetById 0ms app.codeStats 0ms

/pipviewer.spec

#
Unknown | 130 lines | 97 code | 33 blank | 0 comment | 0 complexity | 4445bfd820aeb469937c6b6992f7933d MD5 | raw file
Possible License(s): GPL-3.0
  1. %if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
  2. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  3. %endif
  4. Name: pipviewer
  5. Version: 0.3.9
  6. Release: 12%{?dist}
  7. Summary: Visualizer for multiple alignments of genomic sequences
  8. Group: Applications/Engineering
  9. License: GPLv3+
  10. URL: http://ygingras.net/bioinfo
  11. Source0: http://ygingras.net/files/%{name}-%{version}.tar.gz
  12. #Source1: %{name}.desktop
  13. #Source2: %{name}.png
  14. Patch0: %{name}-setup.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. BuildArch: noarch
  17. BuildRequires: python-devel
  18. BuildRequires: python-setuptools
  19. #BuildRequires: desktop-file-utils
  20. Requires: PyQt
  21. Requires: pygtk2
  22. Requires: PyOpenGL
  23. Requires: vhybridize >= 0.5.9
  24. %description
  25. Pipviewer is a visualizer for multiple alignements of genomic
  26. sequences. It highlights conserved regions and allows basic
  27. anotations. Its main goal is to find conserved probes for the
  28. construction of gene order data sets. Selected regions marked as
  29. 'probes' can be expoxted to fasta format. It can also retreive gene
  30. annotations form the NBCI and display this information along the
  31. alignement.
  32. Pipviewer is not an aligner. You must compute the alignment with
  33. another tool like Clustal or Multi PIP Maker.
  34. %prep
  35. %setup -q
  36. %build
  37. python ./setup.py build
  38. %install
  39. rm -rf %{buildroot}
  40. python ./setup.py install --skip-build --root %{buildroot}
  41. #desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
  42. #install -Dp -m 0644 %{SOURCE2} %{buildroot}%{_datadir}/pixmaps/%{name}.png
  43. #remove shebang
  44. for file in \
  45. %{buildroot}%{python_sitelib}/%{name}/{SpeciesGenomesDialog.py,utils.py,ProbesListDialog.py} \
  46. %{buildroot}%{python_sitelib}/%{name}/{probeAlign.py,ViewerWidget.py,viewer_app.py,pselfiles.py} \
  47. %{buildroot}%{python_sitelib}/%{name}/scripts/pippacker.py; do
  48. sed -i -e '/^#!\//, 1d' $file
  49. done
  50. sed -i 's|OpenGL>=2.0|PyOpenGL>2.0|g' %{buildroot}%{python_sitelib}/pipviewer-0.3.9-py2.*.egg-info/requires.txt
  51. %clean
  52. rm -rf %{buildroot}
  53. %post
  54. touch --no-create %{_datadir}/icons/hicolor
  55. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  56. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  57. fi
  58. %postun
  59. touch --no-create %{_datadir}/icons/hicolor
  60. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  61. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  62. fi
  63. %files
  64. %defattr(-,root,root,-)
  65. %doc AUTHORS.txt COPYING.txt README.txt TODO.txt docs/ examples/
  66. %{_bindir}/%{name}
  67. %{_bindir}/pippacker
  68. #%{_datadir}/applications/%{name}.desktop
  69. #%{_datadir}/pixmaps/%{name}.png
  70. %{python_sitelib}/%{name}/
  71. %{python_sitelib}/%{name}*.egg-info
  72. %changelog
  73. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-12
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  75. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-11
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  77. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-10
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  79. * Mon Jul 26 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.9-9
  80. - generalize 2.6 to 2.* in fixup of egg-info
  81. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3.9-8
  82. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  83. * Sat Jun 19 2010 Fabian Affolter <fabian@bernewireless.net> - 0.3.9-7
  84. - Fixed BZ # 579521
  85. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-6
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  87. * Sat Feb 28 2009 Fabian Affolter <fabian@bernewireless.net> - 0.3.9-5
  88. - Merge Release 4 and #481508
  89. * Fri Feb 27 2009 Fabian Affolter <fabian@bernewireless.net> - 0.3.9-4
  90. - GUI stuff disabled because the application needs a file for the start
  91. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-3
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  93. * Tue Jan 27 2009 Fabian Affolter <fabian@bernewireless.net> - 0.3.9-2
  94. - Fixed buildroot tag
  95. - Changed license to GPLv3+
  96. * Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.3.9-1
  97. - Initial package for Fedora