PageRenderTime 23ms CodeModel.GetById 19ms RepoModel.GetById 0ms app.codeStats 0ms

/package/protobuf/protobuf.mk

https://bitbucket.org/fhunleth/dm36x-buildroot
Makefile | 23 lines | 13 code | 4 blank | 6 comment | 0 complexity | 686a680df37d59397573725134a0e406 MD5 | raw file
Possible License(s): GPL-2.0
  1. #############################################################
  2. #
  3. # protobuf
  4. #
  5. #############################################################
  6. PROTOBUF_VERSION = 2.4.1
  7. PROTOBUF_SOURCE = protobuf-$(PROTOBUF_VERSION).tar.gz
  8. PROTOBUF_SITE = http://protobuf.googlecode.com/files/
  9. PROTOBUF_LICENSE = BSD-3c
  10. PROTOBUF_LICENSE_FILES = COPYING.txt
  11. # N.B. Need to use host protoc during cross compilation.
  12. PROTOBUF_DEPENDENCIES = host-protobuf
  13. PROTOBUF_CONF_OPT = --with-protoc=$(HOST_DIR)/usr/bin/protoc
  14. PROTOBUF_INSTALL_STAGING = YES
  15. ifeq ($(BR2_PACKAGE_ZLIB),y)
  16. PROTOBUF_DEPENDENCIES += zlib
  17. endif
  18. $(eval $(autotools-package))
  19. $(eval $(host-autotools-package))