PageRenderTime 6ms CodeModel.GetById 2ms app.highlight 1ms RepoModel.GetById 1ms app.codeStats 0ms

/js/lib/Socket.IO-node/support/expresso/deps/jscoverage/js/build/autoconf/pkg.m4

http://github.com/onedayitwillmake/RealtimeMultiplayerNodeJs
m4 | 59 lines | 44 code | 9 blank | 6 comment | 0 complexity | d0957672dc0d97bd0426d29fcea8bac4 MD5 | raw file
 1# PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4, action-if, action-not)
 2# defines GSTUFF_LIBS, GSTUFF_CFLAGS, see pkg-config man page
 3# also defines GSTUFF_PKG_ERRORS on error
 4AC_DEFUN([PKG_CHECK_MODULES],
 5[succeeded=no
 6
 7  if test -z "$PKG_CONFIG"; then
 8    AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
 9  fi
10
11  if test "$PKG_CONFIG" = "no" ; then
12     echo "*** The pkg-config script could not be found. Make sure it is"
13     echo "*** in your path, or set the PKG_CONFIG environment variable"
14     echo "*** to the full path to pkg-config."
15     echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
16  else
17     PKG_CONFIG_MIN_VERSION=0.9.0
18     if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
19        AC_MSG_CHECKING(for $2)
20
21        if $PKG_CONFIG --exists "$2" ; then
22            AC_MSG_RESULT(yes)
23            succeeded=yes
24
25            AC_MSG_CHECKING($1_CFLAGS)
26            $1_CFLAGS=`$PKG_CONFIG --cflags "$2"`
27            AC_MSG_RESULT($$1_CFLAGS)
28
29            AC_MSG_CHECKING($1_LIBS)
30            ## Remove evil flags like -Wl,--export-dynamic
31            $1_LIBS="`$PKG_CONFIG --libs \"$2\" |sed s/-Wl,--export-dynamic//g`"
32            AC_MSG_RESULT($$1_LIBS)
33        else
34            $1_CFLAGS=""
35            $1_LIBS=""
36            ## If we have a custom action on failure, don't print errors, but 
37            ## do set a variable so people can do so.
38            $1_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
39            ifelse([$4], ,echo $$1_PKG_ERRORS,)
40        fi
41
42        AC_SUBST($1_CFLAGS)
43        AC_SUBST($1_LIBS)
44     else
45        echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
46        echo "*** See http://www.freedesktop.org/software/pkgconfig"
47     fi
48  fi
49
50  if test $succeeded = yes; then
51     ifelse([$3], , :, [$3])
52  else
53     if test "$COMPILE_ENVIRONMENT"; then 
54       ifelse([$4], , AC_MSG_ERROR([Library requirements ($2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.]), [$4])
55     fi
56  fi
57])
58
59