/qlcplus-git/PKGBUILD

https://bitbucket.org/kaendfinger/aur-mirror · #! · 45 lines · 37 code · 8 blank · 0 comment · 0 complexity · d76171815f7b28516d26db47e6c65979 MD5 · raw file

  1. # Maintainer: Thomas Achtner <info@offtools.de>
  2. pkgname=qlcplus-git
  3. pkgver=20121225
  4. pkgrel=1
  5. pkgdesc="QLC+ is a fork of the great QLC project written by Heikki Junnila. This project aims to continue the development of QLC and to introduce new feature systems"
  6. arch=('i686' 'x86_64')
  7. url="http://github.com/mcallegari/qlcplus"
  8. license=('GPL2' )
  9. depends=('qt' 'libftdi' 'shared-mime-info' 'ola-git')
  10. makedepends=('git')
  11. provides=('qlc')
  12. replaces=('qlc' 'qlc-svn')
  13. _gitroot="https://github.com/mcallegari/qlcplus.git"
  14. _gitname="qlcplus"
  15. build() {
  16. cd "$srcdir"
  17. msg "Connecting to GIT server...."
  18. if [ -d $_gitname ] ; then
  19. cd $_gitname && git pull origin
  20. msg "The local files are updated."
  21. else
  22. git clone $_gitroot $_gitname
  23. fi
  24. msg "GIT checkout done or server timeout"
  25. msg "Starting make..."
  26. rm -rf "$srcdir/$_gitname-build"
  27. git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
  28. cd "$srcdir/$_gitname-build"
  29. qmake INSTALL_ROOT=$pkgdir || return 1
  30. make INSTALL_ROOT=$pkgdir || return 1
  31. make INSTALL_ROOT=$pkgdir install || return 1
  32. rm -rf ${srcdir}/$_git-build
  33. }
  34. package() {
  35. cd "$srcdir/$_gitname-build"
  36. make DESTDIR="$pkgdir/" install
  37. }