/qlcplus-git/PKGBUILD
https://bitbucket.org/kaendfinger/aur-mirror · #! · 45 lines · 37 code · 8 blank · 0 comment · 0 complexity · d76171815f7b28516d26db47e6c65979 MD5 · raw file
- # Maintainer: Thomas Achtner <info@offtools.de>
- pkgname=qlcplus-git
- pkgver=20121225
- pkgrel=1
- pkgdesc="QLC+ is a fork of the great QLC project written by Heikki Junnila. This project aims to continue the development of QLC and to introduce new feature systems"
- arch=('i686' 'x86_64')
- url="http://github.com/mcallegari/qlcplus"
- license=('GPL2' )
- depends=('qt' 'libftdi' 'shared-mime-info' 'ola-git')
- makedepends=('git')
- provides=('qlc')
- replaces=('qlc' 'qlc-svn')
- _gitroot="https://github.com/mcallegari/qlcplus.git"
- _gitname="qlcplus"
- build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
- msg "GIT checkout done or server timeout"
- msg "Starting make..."
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
- qmake INSTALL_ROOT=$pkgdir || return 1
- make INSTALL_ROOT=$pkgdir || return 1
- make INSTALL_ROOT=$pkgdir install || return 1
- rm -rf ${srcdir}/$_git-build
- }
- package() {
- cd "$srcdir/$_gitname-build"
- make DESTDIR="$pkgdir/" install
- }