PageRenderTime 28ms CodeModel.GetById 15ms RepoModel.GetById 0ms app.codeStats 0ms

/contrib/gentoo/ewitool-0.3.ebuild

http://ewitool.googlecode.com/
Unknown | 34 lines | 27 code | 7 blank | 0 comment | 0 complexity | 015c718d39d3a8b5744e2fc922f80ef4 MD5 | raw file
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: $
  4. inherit qt4
  5. DESCRIPTION="A tool for handling the Akai EWI4000s Wind Synthesizer"
  6. HOMEPAGE="http://code.google.com/p/ewitool/"
  7. SRC_URI="http://ewitool.googlecode.com/files/EWItool-${PV}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~x86 ~amd64"
  11. DEPEND=">=x11-libs/qt-4
  12. media-libs/alsa-lib"
  13. pkg_setup() {
  14. if ! built_with_use media-libs/alsa-lib midi; then
  15. eerror "media-libs/alsa-lib needs to be built with midi use flag"
  16. eerror "in order to use ${PN}"
  17. die "Please rebuild media-libs/alsa-lib with midi use flag"
  18. fi
  19. }
  20. src_compile() {
  21. cd EWItool
  22. eqmake4 || die "qmake failed"
  23. emake || die "make failed"
  24. }
  25. src_install() {
  26. dobin EWItool/bin/ewitool
  27. }