PageRenderTime 39ms CodeModel.GetById 12ms RepoModel.GetById 0ms app.codeStats 0ms

/gnu/packages/patches/perl-5.14-no-sys-dirs.patch

https://gitlab.com/janneke/guix
Patch | 156 lines | 147 code | 9 blank | 0 comment | 0 complexity | 6fdab3691f2d6f7e5becf7664a07d21f MD5 | raw file
  1. Don't long for headers and libraries in "traditional" locations.
  2. Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
  3. diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
  4. --- perl-5.14.2-orig/Configure 2011-09-26 11:44:34.000000000 +0200
  5. +++ perl-5.14.2/Configure 2012-01-20 17:05:23.089223129 +0100
  6. @@ -106,15 +106,7 @@
  7. fi
  8. : Proper PATH setting
  9. -paths='/bin /usr/bin /usr/local/bin /usr/ucb /usr/local /usr/lbin'
  10. -paths="$paths /opt/bin /opt/local/bin /opt/local /opt/lbin"
  11. -paths="$paths /usr/5bin /etc /usr/gnu/bin /usr/new /usr/new/bin /usr/nbin"
  12. -paths="$paths /opt/gnu/bin /opt/new /opt/new/bin /opt/nbin"
  13. -paths="$paths /sys5.3/bin /sys5.3/usr/bin /bsd4.3/bin /bsd4.3/usr/ucb"
  14. -paths="$paths /bsd4.3/usr/bin /usr/bsd /bsd43/bin /opt/ansic/bin /usr/ccs/bin"
  15. -paths="$paths /etc /usr/lib /usr/ucblib /lib /usr/ccs/lib"
  16. -paths="$paths /sbin /usr/sbin /usr/libexec"
  17. -paths="$paths /system/gnu_library/bin"
  18. +paths=''
  19. for p in $paths
  20. do
  21. @@ -1311,8 +1303,7 @@
  22. archname=''
  23. : Possible local include directories to search.
  24. : Set locincpth to "" in a hint file to defeat local include searches.
  25. -locincpth="/usr/local/include /opt/local/include /usr/gnu/include"
  26. -locincpth="$locincpth /opt/gnu/include /usr/GNU/include /opt/GNU/include"
  27. +locincpth=""
  28. :
  29. : no include file wanted by default
  30. inclwanted=''
  31. @@ -1328,17 +1319,12 @@
  32. archobjs=''
  33. libnames=''
  34. : change the next line if compiling for Xenix/286 on Xenix/386
  35. -xlibpth='/usr/lib/386 /lib/386'
  36. +xlibpth=''
  37. : Possible local library directories to search.
  38. -loclibpth="/usr/local/lib /opt/local/lib /usr/gnu/lib"
  39. -loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
  40. +loclibpth=""
  41. : general looking path for locating libraries
  42. -glibpth="/lib /usr/lib $xlibpth"
  43. -glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
  44. -test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
  45. -test -f /shlib/libc.so && glibpth="/shlib $glibpth"
  46. -test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
  47. +glibpth=""
  48. : Private path used by Configure to find libraries. Its value
  49. : is prepended to libpth. This variable takes care of special
  50. @@ -1371,8 +1357,6 @@
  51. libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
  52. : We probably want to search /usr/shlib before most other libraries.
  53. : This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
  54. -glibpth=`echo " $glibpth " | sed -e 's! /usr/shlib ! !'`
  55. -glibpth="/usr/shlib $glibpth"
  56. : Do not use vfork unless overridden by a hint file.
  57. usevfork=false
  58. @@ -2380,7 +2364,6 @@
  59. zip
  60. "
  61. pth=`echo $PATH | sed -e "s/$p_/ /g"`
  62. -pth="$pth /lib /usr/lib"
  63. for file in $loclist; do
  64. eval xxx=\$$file
  65. case "$xxx" in
  66. @@ -4785,7 +4768,7 @@
  67. : Set private lib path
  68. case "$plibpth" in
  69. '') if ./mips; then
  70. - plibpth="$incpath/usr/lib /usr/local/lib /usr/ccs/lib"
  71. + plibpth="$incpath/usr/lib"
  72. fi;;
  73. esac
  74. case "$libpth" in
  75. @@ -8390,13 +8373,8 @@
  76. echo " "
  77. case "$sysman" in
  78. '')
  79. - syspath='/usr/share/man/man1 /usr/man/man1'
  80. - syspath="$syspath /usr/man/mann /usr/man/manl /usr/man/local/man1"
  81. - syspath="$syspath /usr/man/u_man/man1"
  82. - syspath="$syspath /usr/catman/u_man/man1 /usr/man/l_man/man1"
  83. - syspath="$syspath /usr/local/man/u_man/man1 /usr/local/man/l_man/man1"
  84. - syspath="$syspath /usr/man/man.L /local/man/man1 /usr/local/man/man1"
  85. - sysman=`./loc . /usr/man/man1 $syspath`
  86. + syspath=''
  87. + sysman=''
  88. ;;
  89. esac
  90. if $test -d "$sysman"; then
  91. @@ -19721,9 +19699,10 @@
  92. case "$full_ar" in
  93. '') full_ar=$ar ;;
  94. esac
  95. +full_ar=ar
  96. : Store the full pathname to the sed program for use in the C program
  97. -full_sed=$sed
  98. +full_sed=sed
  99. : see what type gids are declared as in the kernel
  100. echo " "
  101. diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Errno_pm.PL
  102. --- perl-5.14.2-orig/ext/Errno/Errno_pm.PL 2011-09-26 11:44:34.000000000 +0200
  103. +++ perl-5.14.2/ext/Errno/Errno_pm.PL 2012-01-20 17:02:07.938138311 +0100
  104. @@ -137,11 +137,7 @@
  105. if ($dep =~ /(\S+errno\.h)/) {
  106. $file{$1} = 1;
  107. }
  108. - } elsif ($^O eq 'linux' &&
  109. - $Config{gccversion} ne '' &&
  110. - $Config{gccversion} !~ /intel/i
  111. - # might be using, say, Intel's icc
  112. - ) {
  113. + } elsif (0) {
  114. # Some Linuxes have weird errno.hs which generate
  115. # no #file or #line directives
  116. my $linux_errno_h = -e '/usr/include/errno.h' ?
  117. diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
  118. --- perl-5.14.2-orig/hints/freebsd.sh 2011-09-19 15:18:22.000000000 +0200
  119. +++ perl-5.14.2/hints/freebsd.sh 2012-01-20 17:10:37.267924044 +0100
  120. @@ -118,21 +118,21 @@
  121. objformat=`/usr/bin/objformat`
  122. if [ x$objformat = xaout ]; then
  123. if [ -e /usr/lib/aout ]; then
  124. - libpth="/usr/lib/aout /usr/local/lib /usr/lib"
  125. - glibpth="/usr/lib/aout /usr/local/lib /usr/lib"
  126. + libpth=""
  127. + glibpth=""
  128. fi
  129. lddlflags='-Bshareable'
  130. else
  131. - libpth="/usr/lib /usr/local/lib"
  132. - glibpth="/usr/lib /usr/local/lib"
  133. + libpth=""
  134. + glibpth=""
  135. ldflags="-Wl,-E "
  136. lddlflags="-shared "
  137. fi
  138. cccdlflags='-DPIC -fPIC'
  139. ;;
  140. *)
  141. - libpth="/usr/lib /usr/local/lib"
  142. - glibpth="/usr/lib /usr/local/lib"
  143. + libpth=""
  144. + glibpth=""
  145. ldflags="-Wl,-E "
  146. lddlflags="-shared "
  147. cccdlflags='-DPIC -fPIC'