PageRenderTime 47ms CodeModel.GetById 17ms RepoModel.GetById 0ms app.codeStats 0ms

/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb

https://gitlab.com/oryx/meta-openembedded
Bitbake | 150 lines | 137 code | 13 blank | 0 comment | 0 complexity | d77943d9337b49255a0223960448f1ae MD5 | raw file
  1. SUMMARY = "Meta-oe ptest packagegroups"
  2. inherit packagegroup
  3. PROVIDES = "${PACKAGES}"
  4. PACKAGES = ' \
  5. packagegroup-meta-python \
  6. packagegroup-meta-python3 \
  7. '
  8. RDEPENDS_packagegroup-meta-python = "\
  9. packagegroup-meta-python-extended \
  10. packagegroup-meta-python-connectivity \
  11. "
  12. RDEPENDS_packagegroup-meta-python3 = "\
  13. packagegroup-meta-python3-extended \
  14. packagegroup-meta-python3-connectivity \
  15. "
  16. RDEPENDS_packagegroup-meta-python = "\
  17. python-psutil python-certifi python-flask python-pyroute2 python-pyopenssl python-pylint \
  18. python-semver python-wrapt python-networkx python-behave python-dominate python-flask-user \
  19. python-attrs python-humanize python-six python-flask-login python-zopeinterface python-sijax \
  20. python-pyinotify python-stevedore python-pyjwt python-webdav python-twisted python-flask-sijax \
  21. python-functools32 python-javaobj-py3 python-pygpgme python-future python-attr \
  22. python-flask-xstatic python-m2crypto python-hyperlink python-imaging python-idna python-jinja2 \
  23. python-can python-flask-bcrypt python-requests python-paste python-flask-script python-serpent \
  24. python-cryptography python-pysmi python-xlrd python-appdirs python-jsonpatch python-bcrypt \
  25. python-ndg-httpsclient python-pytest python-linecache2 python-visitor python-backports-abc \
  26. python-setuptools-scm python-evdev python-pyjks python-jsonpointer python-cheetah python-gevent \
  27. python-smbus python-sqlalchemy python-scrypt python-werkzeug python-anyjson python-pexpect \
  28. python-robotframework-seriallibrary python-pyalsaaudio python-pytest-helpers-namespace \
  29. python-alembic python-flask-pymongo python-slip-dbus python-pydbus python-automat python-rfc3987 \
  30. python-tzlocal python-backports-ssl python-subprocess32 python-asn1crypto python-pybind11 \
  31. python-ptyprocess python-babel python-passlib python-oauthlib python-sdnotify \
  32. python-lazy-object-proxy python-cryptography-vectors python-crcmod python-pyusb python-vobject \
  33. python-webcolors python-pyparsing python-beautifulsoup4 python-cffi python-tornado-redis \
  34. python-itsdangerous python-pyasn1-modules python-netaddr python-vcversioner \
  35. python-sh python-greenlet python-paho-mqtt python-traceback2 python-gdata python-dbusmock \
  36. python-whoosh python-lockfile python-isort python-wtforms python-feedparser python-flask-restful \
  37. python-pysnmp python-flask-babel python-pytest-tempdir python-flask-nav python-pyzmq python-pyyaml \
  38. python-protobuf python-pluggy python-jsonschema python-msgpack python-pandas \
  39. python-periphery python-pint python-pycryptodome python-yappi python-pycrypto python-pretend \
  40. python-pyserial python-pyiface python-docutils python-grpcio-tools python-django-south \
  41. python-backports-functools-lru-cache python-py python-click python-flask-migrate \
  42. python-pyudev python-pystache python-blinker python-prompt-toolkit python-lxml \
  43. python-unidiff python-inflection python-twofish python-prettytable python-webencodings \
  44. python-mock python-pyexpect python-dnspython python-pysocks python-pynetlinux \
  45. python-daemon python-djangorestframework python-typing python-monotonic python-sparts \
  46. python-enum34 python-pyperclip python-flask-uploads python-pbr python-parse python-pyflakes \
  47. python-pyhamcrest python-mako python-incremental python-tornado python-xstatic-font-awesome \
  48. python-cmd2 python-strict-rfc3339 python-pycodestyle python-xstatic python-snakefood \
  49. python-pybluez python-flask-navigation python-pyfirmata python-pymongo python-pysqlite \
  50. python-progress python-flask-sqlalchemy python-pymisp python-pip python-ujson python-ply \
  51. python-pep8 python-dateutil python-pycparser python-daemonize python-astroid python-pyrex \
  52. python-markupsafe python-pytest-runner python-grpcio python-mccabe python-pytz python-selectors34 \
  53. python-cython python-chardet python-editor python-flask-bootstrap python-html5lib \
  54. python-singledispatch python-redis python-flask-mail python-funcsigs python-snimpy python-pyasn1 \
  55. python-decorator python-urllib3 python-feedformatter python-matplotlib python-iso8601 \
  56. python-numeric python-robotframework python-django python-simplejson python-wcwidth \
  57. python-configparser python-epydoc python-intervals python-speaklater \
  58. python-aws-iot-device-sdk-python python-constantly python-bitarray python-flask-wtf \
  59. python-parse-type python-ipaddress python-dbus \
  60. ${@bb.utils.contains("DISTRO_FEATURES", "pam", "python-pam pamela", "", d)} \
  61. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python-systemd", "", d)} \
  62. "
  63. RDEPENDS_packagegroup-meta-python3 = "\
  64. python3-pyserial python3-gevent python3-alembic python3-robotframework-seriallibrary \
  65. python3-rfc3987 python3-xlrd python3-bandit python3-constantly python3-inflection \
  66. python3-javaobj-py3 python3-sh python3-pycrypto python3-pyasn1 python3-pydbus python3-wtforms \
  67. python3-pybluez python3-babel python3-parse-type python3-bitarray python3-django-south \
  68. python3-pyusb python3-prctl python3-jinja2 python3-werkzeug python3-pyjks python3-requests-ftp \
  69. python3-behave python3-pyparsing python3-pyyaml python3-tzlocal python3-pretend python3-stevedore \
  70. python3-sijax python3-langtable python3-requests-file python3-crcmod python3-robotframework \
  71. python3-pint python3-coverage python3-iso8601 python3-ndg-httpsclient python3-yappi python3-twofish \
  72. python3-speaklater python3-smbus python3-djangorestframework python3-msgpack python3-jsonpointer \
  73. python3-flask-script python3-cassandra-driver python3-cython python3-ujson python3-aws-iot-device-sdk-python \
  74. python3-pytest-runner python3-pyiface python3-flask-login python3-markupsafe python3-setuptools-scm \
  75. python3-semver python3-sdnotify python3-flask-user python3-tornado python3-jsonpatch python3-pexpect \
  76. python3-progress python3-jsonschema python3-xstatic python3-pyroute2 python3-idna python3-sqlalchemy \
  77. python3-urllib3 python3-flask-mail python3-asn1crypto python3-pyinotify python3-intervals python3-pyperclip \
  78. python3-flask-bootstrap python3-pyudev python3-decorator python3-pybind11 python3-pluggy python3-redis \
  79. python3-pycryptodome python3-passlib python3-dominate python3-ply python3-ntplib python3-serpent python3-wrapt \
  80. python3-attrs python3-appdirs python3-isort python3-evdev python3-incremental python3-click python3-flask-nav \
  81. python3-webcolors python3-dateutil python3-blinker python3-hyperlink python3-lxml python3-pylint \
  82. python3-flask-migrate python3-pytest-tempdir python3-flask-restful python3-feedformatter \
  83. python3-pyasn1-modules python3-scapy python3-html5lib python3-dnspython python3-automat \
  84. python3-itsdangerous python3-pandas python3-pyfirmata python3-protobuf \
  85. python3-flask-babel python3-anyjson python3-flask-xstatic python3-multidict python3-prompt-toolkit \
  86. python3-periphery python3-greenlet python3-pytz python3-pyexpect python3-zopeinterface \
  87. python3-bcrypt python3-xstatic-font-awesome python3-m2crypto python3-parse python3-attr \
  88. python3-beautifulsoup4 python3-pycodestyle python3-oauthlib python3-grpcio python3-scrypt \
  89. python3-pyjwt python3-astroid python3-flask-pymongo python3-wcwidth python3-lazy-object-proxy \
  90. python3-websockets python3-pyzmq python3-pytest python3-chardet python3-vcversioner python3-whoosh \
  91. python3-pymisp python3-certifi python3-psutil python3-flask-sqlalchemy python3-humanize \
  92. python3-grpcio-tools python3-configparser python3-strict-rfc3339 python3-paho-mqtt \
  93. python3-pytest-helpers-namespace python3-flask python3-flask-wtf python3-visitor python3-pynetlinux \
  94. python3-requests python3-cryptography-vectors python3-spidev python3-pid python3-pymongo \
  95. python3-future python3-django python3-unidiff python3-webencodings python3-can python3-pyalsaaudio \
  96. python3-flask-sijax python3-cryptography python3-twisted python3-netaddr python3-pycparser \
  97. python3-flask-uploads python3-pysocks python3-cffi python3-editor python3-ptyprocess \
  98. python3-pyopenssl python3-ordered-set python3-simplejson python3-py \
  99. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
  100. "
  101. RDEPENDS_packagegroup-meta-python-extended = "\
  102. python-pyephem \
  103. python-cson \
  104. python-pywbem \
  105. python-pyparted \
  106. "
  107. RDEPENDS_packagegroup-meta-python3-extended = "\
  108. python3-pykickstart \
  109. python3-meh \
  110. python3-blivet \
  111. python3-pywbem \
  112. python3-pyparted \
  113. ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
  114. "
  115. RDEPENDS_packagegroup-meta-python-connectivity = "\
  116. python-pyro4 \
  117. python-pytun \
  118. python-mprpc \
  119. python-thrift \
  120. python-txws \
  121. python-pyconnman \
  122. python-gsocketpool \
  123. "
  124. RDEPENDS_packagegroup-meta-python3-connectivity = "\
  125. python3-pytun \
  126. python3-mprpc \
  127. python3-pyconnman \
  128. python3-gsocketpool \
  129. "
  130. RDEPENDS_packagegroup-meta-python-ptest = "\
  131. python-pygpgme \
  132. python-cryptography \
  133. "
  134. RDEPENDS_packagegroup-meta-python3-ptest = "\
  135. python3-cryptography \
  136. "
  137. EXCLUDE_FROM_WORLD = "1"