PageRenderTime 37ms CodeModel.GetById 11ms RepoModel.GetById 0ms app.codeStats 0ms

/cartridges/openshift-origin-cartridge-python/openshift-origin-cartridge-python.spec

https://github.com/ncdc/origin-server
Unknown | 262 lines | 224 code | 38 blank | 0 comment | 0 complexity | b27c178300ec8820659eaac91d15d2dc MD5 | raw file
Possible License(s): BSD-3-Clause-No-Nuclear-License-2014, Apache-2.0
  1. %global cartridgedir %{_libexecdir}/openshift/cartridges/python
  2. %global httpdconfdir /etc/openshift/cart.conf.d/httpd/python
  3. Name: openshift-origin-cartridge-python
  4. Version: 1.25.2
  5. Release: 1%{?dist}
  6. Summary: Python cartridge
  7. Group: Development/Languages
  8. License: ASL 2.0
  9. URL: https://www.openshift.com
  10. Source0: http://mirror.openshift.com/pub/openshift-origin/source/%{name}/%{name}-%{version}.tar.gz
  11. Requires: rubygem(openshift-origin-node)
  12. Requires: openshift-origin-node-util
  13. %if 0%{?fedora}%{?rhel} <= 6
  14. Requires: python >= 2.6
  15. Requires: python < 2.7
  16. Requires: scl-utils
  17. BuildRequires: scl-utils-build
  18. #FIXME: Use %scl_require macro to properly define dependencies
  19. Requires: python27
  20. Requires: mod_wsgi >= 3.2
  21. Requires: mod_wsgi < 3.4
  22. %endif
  23. %if 0%{?fedora} >= 19
  24. Requires: python >= 2.7
  25. Requires: python < 2.8
  26. Requires: mod_wsgi >= 3.4
  27. Requires: mod_wsgi < 3.5
  28. %endif
  29. Requires: python-virtualenv
  30. %if 0%{?fedora}%{?rhel} <= 6
  31. Requires: python27-python-pip-virtualenv
  32. Requires: python27-mod_wsgi
  33. Requires: python33-python-virtualenv
  34. Requires: python33-mod_wsgi
  35. %endif
  36. Provides: openshift-origin-cartridge-community-python-2.7 = 2.0.0
  37. Provides: openshift-origin-cartridge-community-python-3.3 = 2.0.0
  38. Provides: openshift-origin-cartridge-python-2.6 = 2.0.0
  39. Obsoletes: openshift-origin-cartridge-community-python-2.7 <= 1.99.9
  40. Obsoletes: openshift-origin-cartridge-community-python-3.3 <= 1.99.9
  41. Obsoletes: openshift-origin-cartridge-python-2.6 <= 1.99.9
  42. BuildArch: noarch
  43. %description
  44. Python cartridge for OpenShift. (Cartridge Format V2)
  45. %prep
  46. %setup -q
  47. %build
  48. %__rm %{name}.spec
  49. %__rm logs/.gitkeep
  50. %__rm run/.gitkeep
  51. %install
  52. %__mkdir -p %{buildroot}%{cartridgedir}
  53. %__cp -r * %{buildroot}%{cartridgedir}
  54. %__mkdir -p %{buildroot}%{httpdconfdir}
  55. %__mkdir -p %{buildroot}%{cartridgedir}/env
  56. %__mkdir -p %{buildroot}%{cartridgedir}/usr/versions/{2.6,2.7,3.3}
  57. %if 0%{?fedora}%{?rhel} <= 6
  58. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/2.7-scl/* %{buildroot}%{cartridgedir}/usr/versions/2.7/
  59. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/3.3-scl/* %{buildroot}%{cartridgedir}/usr/versions/3.3/
  60. %endif
  61. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/2.6/
  62. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/2.7/
  63. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/3.3/
  64. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/shared
  65. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/2.7-scl
  66. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/3.3-scl
  67. %files
  68. %dir %{cartridgedir}
  69. %attr(0755,-,-) %{cartridgedir}/bin/
  70. %dir %{httpdconfdir}
  71. %attr(0755,-,-) %{httpdconfdir}
  72. %if 0%{?fedora}%{?rhel} <= 6
  73. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.6/bin/
  74. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.6/bin/*
  75. %endif
  76. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.7/bin/*
  77. %attr(0755,-,-) %{cartridgedir}/usr/versions/3.3/bin/*
  78. %{cartridgedir}/env
  79. %{cartridgedir}/logs
  80. %{cartridgedir}/metadata
  81. %{cartridgedir}/run
  82. %{cartridgedir}/usr
  83. %doc %{cartridgedir}/README.md
  84. %doc %{cartridgedir}/COPYRIGHT
  85. %doc %{cartridgedir}/LICENSE
  86. %exclude %{cartridgedir}/usr/versions/*/template/*.pyc
  87. %exclude %{cartridgedir}/usr/versions/*/template/*.pyo
  88. %changelog
  89. * Tue May 27 2014 Adam Miller <admiller@redhat.com> 1.25.2-1
  90. - Make READMEs in template repos more obvious (vvitek@redhat.com)
  91. * Fri May 16 2014 Adam Miller <admiller@redhat.com> 1.25.1-1
  92. - bump_minor_versions for sprint 45 (admiller@redhat.com)
  93. * Fri Apr 25 2014 Adam Miller <admiller@redhat.com> 1.24.2-1
  94. - mass bumpspec to fix tags (admiller@redhat.com)
  95. * Fri Apr 25 2014 Adam Miller <admiller@redhat.com>
  96. - mass bumpspec to fix tags (admiller@redhat.com)
  97. * Fri Apr 25 2014 Adam Miller - 1.24.0-2
  98. - bumpspec to mass fix tags
  99. * Wed Apr 16 2014 Troy Dawson <tdawson@redhat.com> 1.23.4-1
  100. - Bumping cartridge versions for sprint 43 (bparees@redhat.com)
  101. * Tue Apr 15 2014 Troy Dawson <tdawson@redhat.com> 1.23.3-1
  102. - move libyaml-devel dependency into python cartridge optional dependencies
  103. (bparees@redhat.com)
  104. - Merge pull request #5260 from ironcladlou/cart-log-vars
  105. (dmcphers+openshiftbot@redhat.com)
  106. - Re-introduce cartridge-scoped log environment vars (ironcladlou@gmail.com)
  107. * Mon Apr 14 2014 Troy Dawson <tdawson@redhat.com> 1.23.2-1
  108. - Python cartridge suddenly stopped installing dependencies
  109. (bparees@redhat.com)
  110. * Wed Apr 09 2014 Adam Miller <admiller@redhat.com> 1.23.1-1
  111. - Removing file listed twice warnings (dmcphers@redhat.com)
  112. - Use named pipes for logshifter redirection where appropriate
  113. (ironcladlou@gmail.com)
  114. - Bug 1074237 - Exclude python template *.pyc and *.pyo from spec file
  115. (jhadvig@redhat.com)
  116. - Merge pull request #5168 from mfojtik/bugzilla/1084379
  117. (dmcphers+openshiftbot@redhat.com)
  118. - Bug 1084379 - Added ensure_httpd_restart_succeed() back into ruby/phpmyadmin
  119. (mfojtik@redhat.com)
  120. - Bug 1084298 - Fixed typo in python control script (mfojtik@redhat.com)
  121. - Merge pull request #5157 from ironcladlou/httpd-pgroup-fix
  122. (dmcphers+openshiftbot@redhat.com)
  123. - Force httpd into its own pgroup (ironcladlou@gmail.com)
  124. - Check the return code before writing PID file in Python start_app()
  125. (mfojtik@redhat.com)
  126. - Fix graceful shutdown logic (ironcladlou@gmail.com)
  127. - bump_minor_versions for sprint 43 (admiller@redhat.com)
  128. * Thu Mar 27 2014 Adam Miller <admiller@redhat.com> 1.22.5-1
  129. - Update Cartridge Versions for Stage Cut (vvitek@redhat.com)
  130. * Wed Mar 26 2014 Adam Miller <admiller@redhat.com> 1.22.4-1
  131. - Bug 1080381 - Fixed problem with httpd based carts restart after force-stop
  132. (mfojtik@redhat.com)
  133. - Report lingering httpd procs following graceful shutdown
  134. (ironcladlou@gmail.com)
  135. * Tue Mar 25 2014 Adam Miller <admiller@redhat.com> 1.22.3-1
  136. - Port cartridges to use logshifter (ironcladlou@gmail.com)
  137. * Fri Mar 21 2014 Adam Miller <admiller@redhat.com> 1.22.2-1
  138. - Bug 1077591 - Add OPENSHIFT_REPO_DIR to python-path in wsgi
  139. (mfojtik@redhat.com)
  140. * Fri Mar 14 2014 Adam Miller <admiller@redhat.com> 1.22.1-1
  141. - Bug 1073934 - Check the ERB safe-level for python openshift.conf.erb
  142. (mfojtik@redhat.com)
  143. - Removing f19 logic (dmcphers@redhat.com)
  144. - Updating cartridge versions (jhadvig@redhat.com)
  145. - bump_minor_versions for sprint 42 (admiller@redhat.com)
  146. * Wed Mar 05 2014 Adam Miller <admiller@redhat.com> 1.21.3-1
  147. - virtualenv and mod_wsgi are required for python 2.6, 2.7 and 3.3.
  148. (bleanhar@redhat.com)
  149. * Mon Mar 03 2014 Adam Miller <admiller@redhat.com> 1.21.2-1
  150. - Merge pull request #4862 from VojtechVitek/fix_bash_regexp
  151. (dmcphers+openshiftbot@redhat.com)
  152. - fix bash regexp in upgrade scripts (vvitek@redhat.com)
  153. - requirements.txt documentation (vvitek@redhat.com)
  154. - Python - DocumentRoot logic, Repository Layout simplification
  155. (vvitek@redhat.com)
  156. - Update python cartridge to support LD_LIBRARY_PATH_ELEMENT
  157. (mfojtik@redhat.com)
  158. - Template cleanup (dmcphers@redhat.com)
  159. * Thu Feb 27 2014 Adam Miller <admiller@redhat.com> 1.21.1-1
  160. - python $OPENSHIFT_PYTHON_REQUIREMENTS_PATH ENV VAR (vvitek@redhat.com)
  161. - bump_minor_versions for sprint 41 (admiller@redhat.com)
  162. * Sun Feb 16 2014 Adam Miller <admiller@redhat.com> 1.20.5-1
  163. - httpd cartridges: OVERRIDE with custom httpd conf (lmeyer@redhat.com)
  164. * Wed Feb 12 2014 Adam Miller <admiller@redhat.com> 1.20.4-1
  165. - Merge pull request #4744 from mfojtik/latest_versions
  166. (dmcphers+openshiftbot@redhat.com)
  167. - Card origin_cartridge_111 - Updated cartridge versions for stage cut
  168. (mfojtik@redhat.com)
  169. - Merge pull request #4729 from tdawson/2014-02/tdawson/fix-obsoletes
  170. (dmcphers+openshiftbot@redhat.com)
  171. - Merge pull request #4372 from maxamillion/admiller/no_defaulttype_apache24
  172. (dmcphers+openshiftbot@redhat.com)
  173. - Fix obsoletes and provides (tdawson@redhat.com)
  174. - This directive throws a deprecation warning in apache 2.4
  175. (admiller@redhat.com)
  176. * Tue Feb 11 2014 Adam Miller <admiller@redhat.com> 1.20.3-1
  177. - Merge pull request #4712 from tdawson/2014-02/tdawson/cartridge-deps
  178. (dmcphers+openshiftbot@redhat.com)
  179. - Bug 1063677 - Show apache running info when run "rhc cartridge status" for
  180. python app (jhadvig@redhat.com)
  181. - Merge pull request #4707 from danmcp/master (dmcphers@redhat.com)
  182. - Cleanup cartridge dependencies (tdawson@redhat.com)
  183. - Merge pull request #4559 from fabianofranz/dev/441
  184. (dmcphers+openshiftbot@redhat.com)
  185. - Bug 888714 - Remove gitkeep files from rpms (dmcphers@redhat.com)
  186. - Removed references to OpenShift forums in several places
  187. (contact@fabianofranz.com)
  188. * Mon Feb 10 2014 Adam Miller <admiller@redhat.com> 1.20.2-1
  189. - Cleaning specs (dmcphers@redhat.com)
  190. - Bug 1060902: Fix relative venv function during install_setup_tools
  191. (ironcladlou@gmail.com)
  192. - Bug 1060295: Make setup reentrant for cp operations (ironcladlou@gmail.com)
  193. - <httpd carts> bug 1060068: ensure extra httpd conf dirs exist
  194. (lmeyer@redhat.com)
  195. * Thu Jan 30 2014 Adam Miller <admiller@redhat.com> 1.20.1-1
  196. - Remove community tag from Python manifests (ironcladlou@gmail.com)
  197. - bump_minor_versions for sprint 40 (admiller@redhat.com)
  198. * Thu Jan 23 2014 Adam Miller <admiller@redhat.com> 1.19.8-1
  199. - Bump up cartridge versions (bparees@redhat.com)
  200. * Mon Jan 20 2014 Adam Miller <admiller@redhat.com> 1.19.7-1
  201. - <perl,python,phpmyadmin carts> bug 1055095 (lmeyer@redhat.com)
  202. * Fri Jan 17 2014 Adam Miller <admiller@redhat.com> 1.19.6-1
  203. - Merge pull request #4502 from sosiouxme/custom-cart-confs
  204. (dmcphers+openshiftbot@redhat.com)
  205. - <python cart> enable providing custom gear server confs (lmeyer@redhat.com)
  206. * Fri Jan 17 2014 Adam Miller <admiller@redhat.com> 1.19.5-1
  207. - Merge pull request #4462 from bparees/cart_data_cleanup
  208. (dmcphers+openshiftbot@redhat.com)
  209. - remove unnecessary cart-data variable descriptions (bparees@redhat.com)
  210. * Tue Jan 14 2014 Adam Miller <admiller@redhat.com> 1.19.4-1
  211. - Merge pull request #4464 from ironcladlou/bz/1052103
  212. (dmcphers+openshiftbot@redhat.com)
  213. - Bug 1052103: Fix template app.py for Python 3.3 (ironcladlou@gmail.com)
  214. * Mon Jan 13 2014 Adam Miller <admiller@redhat.com> 1.19.3-1
  215. - Merge pull request #4461 from ironcladlou/bz/1052059
  216. (dmcphers+openshiftbot@redhat.com)
  217. - Bug 1052059: Fix Python 3.3 venv path references (ironcladlou@gmail.com)
  218. - Bug 1051910: Fix Python 2.6 regressions (ironcladlou@gmail.com)
  219. - Merge pull request #4444 from ironcladlou/dev/python-scl
  220. (dmcphers+openshiftbot@redhat.com)
  221. - Fixing double-slash in python and posgresql cartridge code
  222. (jhadvig@redhat.com)
  223. - Convert Python 3.3 community cart to use SCL Python 3.3
  224. (ironcladlou@gmail.com)