PageRenderTime 42ms CodeModel.GetById 18ms RepoModel.GetById 0ms app.codeStats 0ms

/trunk/CCache/debian/patches/10_lru_cleanup.diff

#
Unknown | 23 lines | 20 code | 3 blank | 0 comment | 0 complexity | eed9486f6689e266b2ca5032e139edbb MD5 | raw file
Possible License(s): LGPL-2.1, Cube, GPL-3.0, 0BSD, GPL-2.0
  1. --- ccache.c (r?Švision 8804)
  2. +++ ccache.c (copie de travail)
  3. @@ -481,6 +481,9 @@
  4. return;
  5. }
  6. + /* update timestamps for LRU cleanup
  7. + also gives output_file a sensible mtime when hard-linking (for make) */
  8. + utime(hashname, NULL);
  9. utime(stderr_file, NULL);
  10. if (strcmp(output_file, "/dev/null") == 0) {
  11. @@ -513,10 +516,6 @@
  12. failed();
  13. }
  14. }
  15. - if (ret == 0) {
  16. - /* update the mtime on the file so that make doesn't get confused */
  17. - utime(output_file, NULL);
  18. - }
  19. /* get rid of the intermediate preprocessor file */
  20. if (i_tmpfile) {