PageRenderTime 55ms CodeModel.GetById 16ms RepoModel.GetById 1ms app.codeStats 0ms

/trunk/CCache/debian/patches/08_manpage_hyphens.diff

#
Unknown | 89 lines | 85 code | 4 blank | 0 comment | 0 complexity | b4427728913f7d7c5b4bbbfdad333d12 MD5 | raw file
Possible License(s): LGPL-2.1, Cube, GPL-3.0, 0BSD, GPL-2.0
  1. Index: ccache.1
  2. ===================================================================
  3. --- ccache.1 (r?Švision 7695)
  4. +++ ccache.1 (copie de travail)
  5. @@ -49,7 +49,7 @@
  6. .IP "\fB-s\fP"
  7. Print the current statistics summary for the cache\&. The
  8. statistics are stored spread across the subdirectories of the
  9. -cache\&. Using "ccache -s" adds up the statistics across all
  10. +cache\&. Using "ccache \-s" adds up the statistics across all
  11. subdirectories and prints the totals\&.
  12. .IP
  13. .IP "\fB-z\fP"
  14. @@ -60,7 +60,7 @@
  15. .IP
  16. .IP "\fB-c\fP"
  17. Clean the cache and re-calculate the cache file count and
  18. -size totals\&. Normally the -c option should not be necessary as ccache
  19. +size totals\&. Normally the \-c option should not be necessary as ccache
  20. keeps the cache below the specified limits at runtime and keeps
  21. statistics up to date on each compile\&. This option is mostly useful
  22. if you manually modify the cache contents or believe that the cache
  23. @@ -100,9 +100,9 @@
  24. cp ccache /usr/local/bin/
  25. - ln -s /usr/local/bin/ccache /usr/local/bin/gcc
  26. - ln -s /usr/local/bin/ccache /usr/local/bin/g++
  27. - ln -s /usr/local/bin/ccache /usr/local/bin/cc
  28. + ln \-s /usr/local/bin/ccache /usr/local/bin/gcc
  29. + ln \-s /usr/local/bin/ccache /usr/local/bin/g++
  30. + ln \-s /usr/local/bin/ccache /usr/local/bin/cc
  31. .fi
  32. @@ -118,7 +118,7 @@
  33. .PP
  34. When run as a compiler front end ccache usually just takes the same
  35. command line options as the compiler you are using\&. The only exception
  36. -to this is the option \&'--ccache-skip\&'\&. That option can be used to tell
  37. +to this is the option \&'\-\-ccache-skip\&'\&. That option can be used to tell
  38. ccache that the next option is definitely not a input filename, and
  39. should be passed along to the compiler as-is\&.
  40. .PP
  41. @@ -128,7 +128,7 @@
  42. of the resulting object file (among other things)\&. The heuristic
  43. ccache uses in this parse is that any string on the command line that
  44. exists as a file is treated as an input file name (usually a C
  45. -file)\&. By using --ccache-skip you can force an option to not be
  46. +file)\&. By using \-\-ccache-skip you can force an option to not be
  47. treated as an input file name and instead be passed along to the
  48. compiler as a command line option\&.
  49. .PP
  50. @@ -238,7 +238,7 @@
  51. .IP "\fBCCACHE_UNIFY\fP"
  52. If you set the environment variable CCACHE_UNIFY
  53. then ccache will use the C/C++ unifier when hashing the pre-processor
  54. -output if -g is not used in the compile\&. The unifier is slower than a
  55. +output if \-g is not used in the compile\&. The unifier is slower than a
  56. normal hash, so setting this environment variable loses a little bit
  57. of speed, but it means that ccache can take advantage of not
  58. recompiling when the changes to the source code consist of
  59. @@ -262,7 +262,7 @@
  60. .PP
  61. By default ccache has a one gigabyte limit on the cache size and no
  62. maximum number of files\&. You can set a different limit using the
  63. -"ccache -M" and "ccache -F" options, which set the size and number of
  64. +"ccache \-M" and "ccache \-F" options, which set the size and number of
  65. files limits\&.
  66. .PP
  67. When these limits are reached ccache will reduce the cache to 20%
  68. @@ -276,7 +276,7 @@
  69. that it is the same code by forming a hash of:
  70. .PP
  71. .IP o
  72. -the pre-processor output from running the compiler with -E
  73. +the pre-processor output from running the compiler with \-E
  74. .IP o
  75. the command line options
  76. .IP o
  77. @@ -331,7 +331,7 @@
  78. .IP o
  79. Make sure that the setgid bit is set on all directories in the
  80. cache\&. This tells the filesystem to inherit group ownership for new
  81. -directories\&. The command "chmod g+s `find $CCACHE_DIR -type d`" might
  82. +directories\&. The command "chmod g+s `find $CCACHE_DIR \-type d`" might
  83. be useful for this\&.
  84. .PP
  85. .SH "HISTORY"