PageRenderTime 25ms CodeModel.GetById 0ms RepoModel.GetById 1ms app.codeStats 0ms

/trunk/debian/rules

#
Makefile | 76 lines | 48 code | 11 blank | 17 comment | 0 complexity | 7e735e36e04dbc55b069b197d587c3ac MD5 | raw file
Possible License(s): LGPL-2.1, Cube, GPL-3.0, 0BSD, GPL-2.0
  1. #!/usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # GNU copyright 1997 to 1999 by Joey Hess.
  4. # Uncomment this to turn on verbose mode.
  5. export DH_VERBOSE=1
  6. # This is the debhelper compatability version to use.
  7. export DH_COMPAT=3
  8. configure: configure-stamp
  9. configure-stamp:
  10. dh_testdir
  11. ./autogen-debian.sh
  12. ./configure --prefix=/usr --mandir=/usr/share/man --with-swiglibdir=/usr/share/swig1.3 --program-suffix=-1.3
  13. touch configure-stamp
  14. build: configure-stamp build-stamp
  15. build-stamp:
  16. dh_testdir
  17. $(MAKE)
  18. $(MAKE) runtime
  19. touch build-stamp
  20. clean:
  21. dh_testdir
  22. dh_testroot
  23. rm -f build-stamp configure-stamp
  24. -$(MAKE) clean
  25. dh_clean
  26. install: build
  27. dh_testdir
  28. dh_testroot
  29. dh_clean -k
  30. dh_installdirs
  31. $(MAKE) install DESTDIR=$(CURDIR)/debian/swig1.3
  32. # Build architecture-independent files here.
  33. binary-indep: build install
  34. # We have nothing to do by default.
  35. # Build architecture-dependent files here.
  36. binary-arch: build install
  37. dh_testdir
  38. dh_testroot
  39. # dh_installdebconf
  40. dh_installdocs
  41. dh_installexamples
  42. dh_installmenu
  43. # dh_installlogrotate
  44. # dh_installemacsen
  45. # dh_installpam
  46. # dh_installmime
  47. # dh_installinit
  48. # dh_installcron
  49. dh_installman
  50. dh_installinfo
  51. dh_undocumented swig-1.3.1
  52. # dh_installchangelogs CHANGES
  53. dh_link
  54. dh_strip
  55. dh_compress
  56. dh_fixperms
  57. dh_makeshlibs
  58. dh_installdeb
  59. # dh_perl
  60. dh_shlibdeps
  61. dh_gencontrol
  62. dh_md5sums
  63. dh_builddeb
  64. binary: binary-indep binary-arch
  65. .PHONY: build clean binary-indep binary-arch binary install configure