PageRenderTime 54ms CodeModel.GetById 28ms RepoModel.GetById 1ms app.codeStats 0ms

/cartridges/openshift-origin-cartridge-python/openshift-origin-cartridge-python.spec

https://github.com/shabesoglu/origin-server
Unknown | 270 lines | 230 code | 40 blank | 0 comment | 0 complexity | e90fa106b497f92f0e9284b05710e3e6 MD5 | raw file
Possible License(s): Apache-2.0, BSD-3-Clause-No-Nuclear-License-2014, GPL-2.0
  1. %global cartridgedir %{_libexecdir}/openshift/cartridges/python
  2. %global httpdconfdir /etc/openshift/cart.conf.d/httpd/python
  3. Name: openshift-origin-cartridge-python
  4. Version: 1.26.1
  5. Release: 1%{?dist}
  6. Summary: Python cartridge
  7. Group: Development/Languages
  8. License: ASL 2.0
  9. URL: https://www.openshift.com
  10. Source0: http://mirror.openshift.com/pub/openshift-origin/source/%{name}/%{name}-%{version}.tar.gz
  11. Requires: rubygem(openshift-origin-node)
  12. Requires: openshift-origin-node-util
  13. %if 0%{?fedora}%{?rhel} <= 6
  14. Requires: python >= 2.6
  15. Requires: python < 2.7
  16. Requires: scl-utils
  17. BuildRequires: scl-utils-build
  18. #FIXME: Use %scl_require macro to properly define dependencies
  19. Requires: python27
  20. Requires: mod_wsgi >= 3.2
  21. Requires: mod_wsgi < 3.4
  22. %endif
  23. %if 0%{?fedora} >= 19
  24. Requires: python >= 2.7
  25. Requires: python < 2.8
  26. Requires: mod_wsgi >= 3.4
  27. Requires: mod_wsgi < 3.5
  28. %endif
  29. Requires: python-virtualenv
  30. %if 0%{?fedora}%{?rhel} <= 6
  31. Requires: python27-python-pip-virtualenv
  32. Requires: python27-mod_wsgi
  33. Requires: python33-python-virtualenv
  34. Requires: python33-mod_wsgi
  35. %endif
  36. Provides: openshift-origin-cartridge-community-python-2.7 = 2.0.0
  37. Provides: openshift-origin-cartridge-community-python-3.3 = 2.0.0
  38. Provides: openshift-origin-cartridge-python-2.6 = 2.0.0
  39. Obsoletes: openshift-origin-cartridge-community-python-2.7 <= 1.99.9
  40. Obsoletes: openshift-origin-cartridge-community-python-3.3 <= 1.99.9
  41. Obsoletes: openshift-origin-cartridge-python-2.6 <= 1.99.9
  42. BuildArch: noarch
  43. %description
  44. Python cartridge for OpenShift. (Cartridge Format V2)
  45. %prep
  46. %setup -q
  47. %build
  48. %__rm %{name}.spec
  49. %__rm logs/.gitkeep
  50. %__rm run/.gitkeep
  51. %install
  52. %__mkdir -p %{buildroot}%{cartridgedir}
  53. %__cp -r * %{buildroot}%{cartridgedir}
  54. %__mkdir -p %{buildroot}%{httpdconfdir}
  55. %__mkdir -p %{buildroot}%{cartridgedir}/env
  56. %__mkdir -p %{buildroot}%{cartridgedir}/usr/versions/{2.6,2.7,3.3}
  57. %if 0%{?fedora}%{?rhel} <= 6
  58. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/2.7-scl/* %{buildroot}%{cartridgedir}/usr/versions/2.7/
  59. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/3.3-scl/* %{buildroot}%{cartridgedir}/usr/versions/3.3/
  60. %endif
  61. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/2.6/
  62. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/2.7/
  63. %__cp -anv %{buildroot}%{cartridgedir}/usr/versions/shared/* %{buildroot}%{cartridgedir}/usr/versions/3.3/
  64. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/shared
  65. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/2.7-scl
  66. %__rm -rf %{buildroot}%{cartridgedir}/usr/versions/3.3-scl
  67. %files
  68. %dir %{cartridgedir}
  69. %attr(0755,-,-) %{cartridgedir}/bin/
  70. %dir %{httpdconfdir}
  71. %attr(0755,-,-) %{httpdconfdir}
  72. %if 0%{?fedora}%{?rhel} <= 6
  73. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.6/bin/
  74. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.6/bin/*
  75. %endif
  76. %attr(0755,-,-) %{cartridgedir}/usr/versions/2.7/bin/*
  77. %attr(0755,-,-) %{cartridgedir}/usr/versions/3.3/bin/*
  78. %{cartridgedir}/env
  79. %{cartridgedir}/logs
  80. %{cartridgedir}/metadata
  81. %{cartridgedir}/run
  82. %{cartridgedir}/usr
  83. %doc %{cartridgedir}/README.md
  84. %doc %{cartridgedir}/COPYRIGHT
  85. %doc %{cartridgedir}/LICENSE
  86. %exclude %{cartridgedir}/usr/versions/*/template/*.pyc
  87. %exclude %{cartridgedir}/usr/versions/*/template/*.pyo
  88. %changelog
  89. * Thu Jun 05 2014 Adam Miller <admiller@redhat.com> 1.26.1-1
  90. - bump_minor_versions for sprint 46 (admiller@redhat.com)
  91. * Thu May 29 2014 Adam Miller <admiller@redhat.com> 1.25.3-1
  92. - Merge pull request #5465 from ncdc/python-3.3-pip (admiller@redhat.com)
  93. - Add pip installer to the python cartridge (agoldste@redhat.com)
  94. - Bump cartridge versions (agoldste@redhat.com)
  95. * Tue May 27 2014 Adam Miller <admiller@redhat.com> 1.25.2-1
  96. - Make READMEs in template repos more obvious (vvitek@redhat.com)
  97. * Fri May 16 2014 Adam Miller <admiller@redhat.com> 1.25.1-1
  98. - bump_minor_versions for sprint 45 (admiller@redhat.com)
  99. * Fri Apr 25 2014 Adam Miller <admiller@redhat.com> 1.24.2-1
  100. - mass bumpspec to fix tags (admiller@redhat.com)
  101. * Fri Apr 25 2014 Adam Miller <admiller@redhat.com>
  102. - mass bumpspec to fix tags (admiller@redhat.com)
  103. * Fri Apr 25 2014 Adam Miller - 1.24.0-2
  104. - bumpspec to mass fix tags
  105. * Wed Apr 16 2014 Troy Dawson <tdawson@redhat.com> 1.23.4-1
  106. - Bumping cartridge versions for sprint 43 (bparees@redhat.com)
  107. * Tue Apr 15 2014 Troy Dawson <tdawson@redhat.com> 1.23.3-1
  108. - move libyaml-devel dependency into python cartridge optional dependencies
  109. (bparees@redhat.com)
  110. - Merge pull request #5260 from ironcladlou/cart-log-vars
  111. (dmcphers+openshiftbot@redhat.com)
  112. - Re-introduce cartridge-scoped log environment vars (ironcladlou@gmail.com)
  113. * Mon Apr 14 2014 Troy Dawson <tdawson@redhat.com> 1.23.2-1
  114. - Python cartridge suddenly stopped installing dependencies
  115. (bparees@redhat.com)
  116. * Wed Apr 09 2014 Adam Miller <admiller@redhat.com> 1.23.1-1
  117. - Removing file listed twice warnings (dmcphers@redhat.com)
  118. - Use named pipes for logshifter redirection where appropriate
  119. (ironcladlou@gmail.com)
  120. - Bug 1074237 - Exclude python template *.pyc and *.pyo from spec file
  121. (jhadvig@redhat.com)
  122. - Merge pull request #5168 from mfojtik/bugzilla/1084379
  123. (dmcphers+openshiftbot@redhat.com)
  124. - Bug 1084379 - Added ensure_httpd_restart_succeed() back into ruby/phpmyadmin
  125. (mfojtik@redhat.com)
  126. - Bug 1084298 - Fixed typo in python control script (mfojtik@redhat.com)
  127. - Merge pull request #5157 from ironcladlou/httpd-pgroup-fix
  128. (dmcphers+openshiftbot@redhat.com)
  129. - Force httpd into its own pgroup (ironcladlou@gmail.com)
  130. - Check the return code before writing PID file in Python start_app()
  131. (mfojtik@redhat.com)
  132. - Fix graceful shutdown logic (ironcladlou@gmail.com)
  133. - bump_minor_versions for sprint 43 (admiller@redhat.com)
  134. * Thu Mar 27 2014 Adam Miller <admiller@redhat.com> 1.22.5-1
  135. - Update Cartridge Versions for Stage Cut (vvitek@redhat.com)
  136. * Wed Mar 26 2014 Adam Miller <admiller@redhat.com> 1.22.4-1
  137. - Bug 1080381 - Fixed problem with httpd based carts restart after force-stop
  138. (mfojtik@redhat.com)
  139. - Report lingering httpd procs following graceful shutdown
  140. (ironcladlou@gmail.com)
  141. * Tue Mar 25 2014 Adam Miller <admiller@redhat.com> 1.22.3-1
  142. - Port cartridges to use logshifter (ironcladlou@gmail.com)
  143. * Fri Mar 21 2014 Adam Miller <admiller@redhat.com> 1.22.2-1
  144. - Bug 1077591 - Add OPENSHIFT_REPO_DIR to python-path in wsgi
  145. (mfojtik@redhat.com)
  146. * Fri Mar 14 2014 Adam Miller <admiller@redhat.com> 1.22.1-1
  147. - Bug 1073934 - Check the ERB safe-level for python openshift.conf.erb
  148. (mfojtik@redhat.com)
  149. - Removing f19 logic (dmcphers@redhat.com)
  150. - Updating cartridge versions (jhadvig@redhat.com)
  151. - bump_minor_versions for sprint 42 (admiller@redhat.com)
  152. * Wed Mar 05 2014 Adam Miller <admiller@redhat.com> 1.21.3-1
  153. - virtualenv and mod_wsgi are required for python 2.6, 2.7 and 3.3.
  154. (bleanhar@redhat.com)
  155. * Mon Mar 03 2014 Adam Miller <admiller@redhat.com> 1.21.2-1
  156. - Merge pull request #4862 from VojtechVitek/fix_bash_regexp
  157. (dmcphers+openshiftbot@redhat.com)
  158. - fix bash regexp in upgrade scripts (vvitek@redhat.com)
  159. - requirements.txt documentation (vvitek@redhat.com)
  160. - Python - DocumentRoot logic, Repository Layout simplification
  161. (vvitek@redhat.com)
  162. - Update python cartridge to support LD_LIBRARY_PATH_ELEMENT
  163. (mfojtik@redhat.com)
  164. - Template cleanup (dmcphers@redhat.com)
  165. * Thu Feb 27 2014 Adam Miller <admiller@redhat.com> 1.21.1-1
  166. - python $OPENSHIFT_PYTHON_REQUIREMENTS_PATH ENV VAR (vvitek@redhat.com)
  167. - bump_minor_versions for sprint 41 (admiller@redhat.com)
  168. * Sun Feb 16 2014 Adam Miller <admiller@redhat.com> 1.20.5-1
  169. - httpd cartridges: OVERRIDE with custom httpd conf (lmeyer@redhat.com)
  170. * Wed Feb 12 2014 Adam Miller <admiller@redhat.com> 1.20.4-1
  171. - Merge pull request #4744 from mfojtik/latest_versions
  172. (dmcphers+openshiftbot@redhat.com)
  173. - Card origin_cartridge_111 - Updated cartridge versions for stage cut
  174. (mfojtik@redhat.com)
  175. - Merge pull request #4729 from tdawson/2014-02/tdawson/fix-obsoletes
  176. (dmcphers+openshiftbot@redhat.com)
  177. - Merge pull request #4372 from maxamillion/admiller/no_defaulttype_apache24
  178. (dmcphers+openshiftbot@redhat.com)
  179. - Fix obsoletes and provides (tdawson@redhat.com)
  180. - This directive throws a deprecation warning in apache 2.4
  181. (admiller@redhat.com)
  182. * Tue Feb 11 2014 Adam Miller <admiller@redhat.com> 1.20.3-1
  183. - Merge pull request #4712 from tdawson/2014-02/tdawson/cartridge-deps
  184. (dmcphers+openshiftbot@redhat.com)
  185. - Bug 1063677 - Show apache running info when run "rhc cartridge status" for
  186. python app (jhadvig@redhat.com)
  187. - Merge pull request #4707 from danmcp/master (dmcphers@redhat.com)
  188. - Cleanup cartridge dependencies (tdawson@redhat.com)
  189. - Merge pull request #4559 from fabianofranz/dev/441
  190. (dmcphers+openshiftbot@redhat.com)
  191. - Bug 888714 - Remove gitkeep files from rpms (dmcphers@redhat.com)
  192. - Removed references to OpenShift forums in several places
  193. (contact@fabianofranz.com)
  194. * Mon Feb 10 2014 Adam Miller <admiller@redhat.com> 1.20.2-1
  195. - Cleaning specs (dmcphers@redhat.com)
  196. - Bug 1060902: Fix relative venv function during install_setup_tools
  197. (ironcladlou@gmail.com)
  198. - Bug 1060295: Make setup reentrant for cp operations (ironcladlou@gmail.com)
  199. - <httpd carts> bug 1060068: ensure extra httpd conf dirs exist
  200. (lmeyer@redhat.com)
  201. * Thu Jan 30 2014 Adam Miller <admiller@redhat.com> 1.20.1-1
  202. - Remove community tag from Python manifests (ironcladlou@gmail.com)
  203. - bump_minor_versions for sprint 40 (admiller@redhat.com)
  204. * Thu Jan 23 2014 Adam Miller <admiller@redhat.com> 1.19.8-1
  205. - Bump up cartridge versions (bparees@redhat.com)
  206. * Mon Jan 20 2014 Adam Miller <admiller@redhat.com> 1.19.7-1
  207. - <perl,python,phpmyadmin carts> bug 1055095 (lmeyer@redhat.com)
  208. * Fri Jan 17 2014 Adam Miller <admiller@redhat.com> 1.19.6-1
  209. - Merge pull request #4502 from sosiouxme/custom-cart-confs
  210. (dmcphers+openshiftbot@redhat.com)
  211. - <python cart> enable providing custom gear server confs (lmeyer@redhat.com)
  212. * Fri Jan 17 2014 Adam Miller <admiller@redhat.com> 1.19.5-1
  213. - Merge pull request #4462 from bparees/cart_data_cleanup
  214. (dmcphers+openshiftbot@redhat.com)
  215. - remove unnecessary cart-data variable descriptions (bparees@redhat.com)
  216. * Tue Jan 14 2014 Adam Miller <admiller@redhat.com> 1.19.4-1
  217. - Merge pull request #4464 from ironcladlou/bz/1052103
  218. (dmcphers+openshiftbot@redhat.com)
  219. - Bug 1052103: Fix template app.py for Python 3.3 (ironcladlou@gmail.com)
  220. * Mon Jan 13 2014 Adam Miller <admiller@redhat.com> 1.19.3-1
  221. - Merge pull request #4461 from ironcladlou/bz/1052059
  222. (dmcphers+openshiftbot@redhat.com)
  223. - Bug 1052059: Fix Python 3.3 venv path references (ironcladlou@gmail.com)
  224. - Bug 1051910: Fix Python 2.6 regressions (ironcladlou@gmail.com)
  225. - Merge pull request #4444 from ironcladlou/dev/python-scl
  226. (dmcphers+openshiftbot@redhat.com)
  227. - Fixing double-slash in python and posgresql cartridge code
  228. (jhadvig@redhat.com)
  229. - Convert Python 3.3 community cart to use SCL Python 3.3
  230. (ironcladlou@gmail.com)